Rendu lent sur premiere avec GTX1070

Discussion dans 'Informatique et vidéo' créé par xquasimofox, 2 Septembre 2018.

Tags:
  1. xquasimofox

    Points Repaire:
    675
    Recos reçues:
    0
    Messages:
    18
    Appréciations:
    +0 / 0 / -0
    Salut,

    Je fais du montage multicam (concert) de manière amateur, sous premiere pro CC et j'avais avant une carte quadro 6000 6go de ram, mais elle a rendue l'âme et j'ai investie dans une Asus GTX 1070 8go mais les rendus sont trés longs (y'a du neat video sur chaque rushs car j'utilise des caméras hd amateur pas terrible en basse lumière). Les rendus en utilisant le GPU est 2 fois plus long qu'avec l'ancienne carte Quadro 6000.

    Ma config:
    Station de travail HP Z800
    2 processeur Intel Xeon X5650 2.67GHz
    24 go de ram
    windows 7 pro 64 btis
    disque SSD système 256go
    disque SSD fichiers caches 128go
    disque SSD fichiers travail 512 go

    D'aprés l'utilitaire fournie avec la carte le GTX 1070, le GPU est utilisé à 100% mais la ram de la carte seulement à 2%.

    Pour info pour une vidéos de 45 mins en full HD 50p avec 5 cams, le rendu (avec du neat video sur chaque sources) dure 15 heures.
    Avant en en utilisant le cpu (mercury engine rendering) cela durait 8/9 heures.
    Je suis trés deçu car on m'avait dit qu'en prenant une carte récente avec plein de coeurs Cuda (1920) le rendu serait beaucoup plus rapide. (y'en avait dans les 500 dans la Quadro 6000).

    Y'a t'il une astuce pour optimiser le rendu avec une GTX 1070 ou dois-je repasser avec le rendu cpu (mercury engine rendering)?

    Merci
     
  2. MyPOV

    So

    Points Repaire:
    6 375
    Recos reçues:
    40
    Messages:
    3 023
    Appréciations:
    +177 / 499 / -2
    Bonjour,

    Quel codec est utilisé ? Utilises-tu le plugin Voukoder qui permet d'exploiter l’accélération matériel des cartes vidéos pour le H264 et H265 ?

    Cuda a un impact important pour les effets qui le prennent en charge.

    La carte est bien reconnue par Premiere ?
     
  3. xquasimofox

    Points Repaire:
    675
    Recos reçues:
    0
    Messages:
    18
    Appréciations:
    +0 / 0 / -0
    Salut, merci pour la réponse.
    J'exporte en H264. La carte est bien reconnue par Premiere.
    Je ne connais pas le plugin Voukoder, y'a t-il vraiment un réel gain à l'utiliser?
    Sinon je repasse sur export par le cpu...
     
  4. ogt

    ogt
    Conseiller Technique So

    Points Repaire:
    17 495
    Recos reçues:
    470
    Messages:
    18 610
    Appréciations:
    +400 / 840 / -26
    Quelle version de Neat Video : seule la dernière version utilise correctement le GPu.
    Ce qui me parait anormal c'est une utilisation du GPU à 100% et seulement 2% pour la RAM, alors que Neatvideo est réputé pour utiliser intensivement la RAM vidéo.
    Vous contrôlez avec GPU-Z ?

    Olivier.
     
  5. ogt

    ogt
    Conseiller Technique So

    Points Repaire:
    17 495
    Recos reçues:
    470
    Messages:
    18 610
    Appréciations:
    +400 / 840 / -26
    Attention :
    l'utilisation de Cuda dans Premiere et dans Neatvideo sont complètement indépendants.
    Si vous utilisez Neatvideo sur tous les clips il est bien sûr fondamental d'activer l'accélération graphique dans ce plugin.
    Il y a d'ailleurs une fonction qui permet d'optimiser entre le CPU et le GPU (voir image)

    Olivier
     

    Fichiers attachés:

  6. caraibe

    So

    Points Repaire:
    12 025
    Recos reçues:
    142
    Messages:
    12 960
    Appréciations:
    +122 / 517 / -12
    oooooo
    Je n'utilise pas neat vidéo car ma caméra est assez propre en basse lumière ..Je sais que ça ralenti pas mal les rendus ..mais tout de même !!
    5 caméras :
    Tu passes d'une caméra à l'autre je suppose, donc ça ne doit pas influer sur la vitesse des rendus sauf si tu fais 5 incrustation d'images.
    Je travaille en 4k 25p et suivant correction colorimétriques j'ai des rendus entre 0.6 et 1.7 fois le temps réel !! et cela avec une config qui a 7 ans !!!
    Voir détail dans profil.
    J'utilise le plug Voukoder :good: pour mes exports en HEVC qui est très rapide ...
    J'ai eu mesuré 22mn pour un mariage en église de 45mm.
    je me souviens plus si l'export était en 4k HECV ou en H264 FHD
    Mais jamais testé avec neat vidéo.
    Faudrait peut être lors d'un export que tu mettes GPUZ et le gestionnaire des taches ou coretemp en marche pour voir comment le travail se répartit entre GPU et CPU !
     
    #6 caraibe, 2 Septembre 2018
    Dernière édition: 3 Septembre 2018
  7. xquasimofox

    Points Repaire:
    675
    Recos reçues:
    0
    Messages:
    18
    Appréciations:
    +0 / 0 / -0
    J'utilise le 3.5.0 de Neat Video.
    J'ai ça comme message dans neat video quand je lui dit de détecter le gpu:

    Looking for NVIDIA CUDA-capable devices...
    NVIDIA CUDA initialized successfully.
    Checking CUDA GPU #1:
    GPU device name is: GeForce GTX 1070
    Unsupported compute capability: 6.1
    Check failed - will not use the device

    Ensuite je n'ai pas mis à jour ma carte graphique avec les derniers drivers dispos, j'ai dejà eu des soucis de compatibilité avec des pilotes.
     
    #7 xquasimofox, 2 Septembre 2018
    Dernière édition par un modérateur: 2 Septembre 2018
  8. xquasimofox

    Points Repaire:
    675
    Recos reçues:
    0
    Messages:
    18
    Appréciations:
    +0 / 0 / -0
    Je viens d'installer GPU-Z, il me dit que le GPU est utilisé à 1%, la v-Ram à 2% et que mon port PCI express est configuré en 1.1 ...
     
  9. ogt

    ogt
    Conseiller Technique So

    Points Repaire:
    17 495
    Recos reçues:
    470
    Messages:
    18 610
    Appréciations:
    +400 / 840 / -26
    Malheureusement la version 3.5.0 ne connait pas les cartes graphiques de la série 10xx, trop récentes.
    Il faut donc upgrader Neatvideo si vous voulez en tirer parti.
    Et sans accélération graphique, Neatvideo sur tous les clips, c'est très très long....

    Vous pouvez essayer la derniere version 4.7.1 (en mode démo), pour vérifier que cela fonctionne bien avec votre carte. GTX 1070.

    Olivier
     
  10. xquasimofox

    Points Repaire:
    675
    Recos reçues:
    0
    Messages:
    18
    Appréciations:
    +0 / 0 / -0
    OK, je viens de faire des test d'encodage avec GPU-Z (sans neat video) et le GPU-load reste à 1% alors qu'en faisant le render test cela monte à 98%. Il semblerait que premiere n'utilise pas les cuda alors qu'il a reconnue la carte et que le rendu cuda est activé.
     
  11. ogt

    ogt
    Conseiller Technique So

    Points Repaire:
    17 495
    Recos reçues:
    470
    Messages:
    18 610
    Appréciations:
    +400 / 840 / -26
    Si dans votre montage il n'y a aucun effet pris en charge par cuda, ou aucune mise à l'échelle, c'est normal que le Gpu-load reste très faible, l'accélération graphique n'est pas utilisée.
    Mettez des effets colorimétriques, et vous verrez la différence.

    Olivier
     
  12. xquasimofox

    Points Repaire:
    675
    Recos reçues:
    0
    Messages:
    18
    Appréciations:
    +0 / 0 / -0
    Effectivement avec une correction colorimétrique le GPU est utilisé mais je trouve le rendu long, à peu prés 1x la timeline.
     
  13. ogt

    ogt
    Conseiller Technique So

    Points Repaire:
    17 495
    Recos reçues:
    470
    Messages:
    18 610
    Appréciations:
    +400 / 840 / -26
    Vous êtes dans la norme, un export en H264, sans effets, prend en moyenne entre 0,8 et 2 fois le temps réel en fonction du processeur utilisé.
    Essayez avec le plugin Voukoder, vous allez passer en dessous du temps réel.

    Olivier
     
  14. xquasimofox

    Points Repaire:
    675
    Recos reçues:
    0
    Messages:
    18
    Appréciations:
    +0 / 0 / -0
    Je viens d'essayer Voukoder, je passe à 1/3 de la durée de la timeline sur le rendu, merci beaucoup pour l'astuce! ;)
    J'ai essayé la version V4 de neat video et effectivement ça va plus vite et utilise bien le GPU, va falloir passer à la casserole...
    Sinon j'ai vu que ma carte chauffait pas mal avec voukoder (77°), est-ce dangereux pour la carte graphique sur de long encodages?
     
  15. caraibe

    So

    Points Repaire:
    12 025
    Recos reçues:
    142
    Messages:
    12 960
    Appréciations:
    +122 / 517 / -12
    Je viens de corriger ma faute de frappe ..J'avais écrit voudoker ..Mais tu as trouvé quand même !
    Mais MyPov l'avait correctement signalé !
    3 fois plus rapide que les exports avec le outils de Première..c'est ça !!!
    :bravo:au développeur ...Qui préférerait surement un petit don que mon bravo :o
    Non 77° je ne pense pas que ce soit dangereux
     
Chargement...

Partager cette page