Nous suivre

  1. Evénement éditorial Repaire : Prise en main Canon XF705 (événement gratuit)
    Le 24 avril, on se retrouve pour décortiquer la Canon XF705 avec Greg ! Toutes les infos

    Rejeter la notice

Rendu CUDA premier pro

Discussion dans 'Adobe Premiere Pro' créé par Bibuus, 1 Avril 2019.

  1. Bibuus

    Points Repaire:
    550
    Recos reçues:
    0
    Messages:
    23
    Appréciations:
    +0 / 0 / -0
    Bonjour, je suis nouveau par ici même si cela fait pas mal de temps que je lis sur ce forum :good:

    Je travaille sur Adobe Premier Pro CC 2018.

    Je vous explique mon problème. Je fait un rendu d'une vidéo avec pas mal (voire beaucoup) d'effets comme lumetri et transformation etc... Mais par rapport à ma config je trouve qu'il prend bien trop de temps. J'ai le CUDA activé mais mon GPU ne dépasse pas les 1% :weird: d'utilisation lors du rendu et mon CPU est à 100% (pauvre i5 qui ne calcule pas fort :hum:). C'est anormal vu que les effets sont pourtant le coeur de cette option. (enfin je crois). En plus, lors de mes rendus, une erreur de compilation apparait (en plus du temps que ca met ~ 50 minutes pour un clip avec beaucoup d'effets certes, de 6min20)
    J'ai les derniers drivers game ready de NVIDIA si ça peut aider. :help:

    Ma config :love: :

    I5 9600K
    RTX 2070 8GO
    16 GO RAM 2400
    Win 10
     
  2. MyPOV

    So

    Points Repaire:
    7 900
    Recos reçues:
    51
    Messages:
    4 071
    Appréciations:
    +252 / 637 / -4
    Bonjour et bienvenue,

    Dans quel format exportes-tu ?
    Tu devrais tester le plugin Voukoder qui permet d'exploiter le rendu par GPU de ta Nvidia alors qu'il est fait par le CPU dans ton cas.

    Il y a une longue discussion à son sujet :
    Encodage Premiere en X264 x265, Nvidia ou AMD, VBR, CQP, AC3, MKV etc | Le Repaire

    J'espère ton retour parce que tu serais le premier avec qui je discute qui dispose d'une RTX et donc qui a accès au nouveau codage vidéo H265.
     
  3. ogt

    ogt
    Conseiller Technique So

    Points Repaire:
    17 200
    Recos reçues:
    483
    Messages:
    19 952
    Appréciations:
    +480 / 958 / -29
    Tout a fait anormal !
    Lumetri est un gros consommateur de ressources Cuda, donc l'utilisation du GPU devrait être significative.
    Il y a un parmètre quelque part qui ne doit pas coller :
    Vérifier que dans le projet "Accélération Mercury playback engine" est bien actif, idem pour Système de Rendu dans MediaEncoder.

    Olivier
     
  4. Bibuus

    Points Repaire:
    550
    Recos reçues:
    0
    Messages:
    23
    Appréciations:
    +0 / 0 / -0
    Merci pour vos réponses.
    Je suis pas trop calé au sujet de l'exportation, néanmoins je peux vous assurer que :
    - j'exporte en H264 (pas de 265 disponible dans PP 2018 ?) MP4.
    - j'ai bien activé l'option CUDA dans mes paramètres

    Je vais tester le plug-in mais cela ne marcherait-il pas mieux si je trouve une solution afin d'exporter avec le système préinstallé dans premier ?

    Je n'exporte que par le système de rendu premier et pas par encoder (que je ne possède pas... :/)

    Je serais très prenneur de tout tips concernant l'exportation et les preset afin d'avoir un rendu plus rapide et de bonne qualité, ainsi qu'un fichier de taille modeste.

    Là où je suis perdu c'est comme je l'ai déjà dis, mon GPU n'est absolument pas actif alors que l'option est belle et bien activée et ma carte est bien détectée dans l'exécutable "sniffer" ou quelques chose comme ça.

    J'attend vos réponses avec hâte :good:

    UPLOAD : j'ai réussi à faire mon rendu en supprimant mon effet (R.I.P)
    Le rendu a duré 1H pour 6min20 de vidéo. Médiocre.
     
  5. ogt

    ogt
    Conseiller Technique So

    Points Repaire:
    17 200
    Recos reçues:
    483
    Messages:
    19 952
    Appréciations:
    +480 / 958 / -29
    Effectivement:
    Avec votre configuration le rendu ne devrait pas durer plus que la longueur du film. (0,6 fois la durée du film avec le plugin Voukoder).

    J'ai des doutes sur l'authenticité de votre version.
    Ces deux options sont standard dans la version "officielle" CC2018.

    Olivier
     
  6. Bibuus

    Points Repaire:
    550
    Recos reçues:
    0
    Messages:
    23
    Appréciations:
    +0 / 0 / -0
    Le Creative Cloud m'a été installé par un ami en faculté de mathématiques je doute qu'elle soit authentique. Qu'est ce que cela m'apporterait en terme de rendu etc... de me fournir les logiciels plus récent en souscrivant à un abonnement ?
     
  7. ogt

    ogt
    Conseiller Technique So

    Points Repaire:
    17 200
    Recos reçues:
    483
    Messages:
    19 952
    Appréciations:
    +480 / 958 / -29
    Commencez par tester la version "officielle" pleinement opérationnelle pendant 7 jours, avec les bons paramètres :
    - identifier les caractéristiques de clips avec Mediainfo
    - définir une séquence avec ces même caractéristiques
    - exporter dans un format identique (codec, résolution, fréquence image et conteneur).

    Olivier
     
  8. Bibuus

    Points Repaire:
    550
    Recos reçues:
    0
    Messages:
    23
    Appréciations:
    +0 / 0 / -0
    D'accord ce sera fait.

    J'ai installé le plug-in mais aucun changement à part l'apparition du H265 dans mes paramètres de rendu. Y aurait-il un endroit où je pourrait activer l'équivalent de l'option CUDA sur le plug-in ? Je ne suis pas très calé dans le domaine. Merci de votre aide.
     
  9. MyPOV

    So

    Points Repaire:
    7 900
    Recos reçues:
    51
    Messages:
    4 071
    Appréciations:
    +252 / 637 / -4
    Tu devrais avoir ceci de disponible, sinon peut-être que ton driver Nvidia est trop ancien, il faut le mettre à jour.

    b.PNG
     
  10. Bibuus

    Points Repaire:
    550
    Recos reçues:
    0
    Messages:
    23
    Appréciations:
    +0 / 0 / -0
    J'ai bien trouvé ces fonctionnalités.

    Point positif : Ma carte graphique monte jusque 15% d'utilisation lors de l'encodage pour des périodes d'une à deux secondes.

    Point négatif : la durée du rendu reste presque inchangée (~40 minutes). Je suis encore loin des performances suggérées.

    UPDATE PHOTOS. Les 13 minutes ne font qu'augmenter vous l'aurez bien compris. Sansgg titre.png dzadz.png graphique.png Sans titre.png Sansgg titre.png
     
  11. MyPOV

    So

    Points Repaire:
    7 900
    Recos reçues:
    51
    Messages:
    4 071
    Appréciations:
    +252 / 637 / -4
    As-tu bien pris le codec NVIDIA NVENC H.264 encoder ? Si oui et si tu ne gagnes pas autant qu'espérer alors c'est que ton projet nécessite des rendus non pris en charge par Cuda et calculés par le CPU.

    Tu devrais faire un premier essai d'export sans appliquer tes effets pour constater la vitesse de rendu en comparant le H264 d'origine de Premiere puis celui de Voukoder.

    On désactive un effet en cliquant sur l’icône Fx à sa gauche :
    c.PNG
     
  12. Bibuus

    Points Repaire:
    550
    Recos reçues:
    0
    Messages:
    23
    Appréciations:
    +0 / 0 / -0
    J'ai bien pris ce codec.
    Je vais faire mes test, mais mes effets sont issus des pack sapphire ainsi que les lumetri et transformation de bases... le coeur de CUDA n'est-ce pas ? o_O

    Je me demande donc si je n'ai pas un soucis quelque part que ce soit la présence ou le bon fonctionnement de CUDA, ou bien sur mon PC en général ?
     
  13. MyPOV

    So

    Points Repaire:
    7 900
    Recos reçues:
    51
    Messages:
    4 071
    Appréciations:
    +252 / 637 / -4
    Pour tenter de cerner un éventuel il faut décomposer les choses donc faire un rendu sans effet avec Voukoder pour être sûr que cela fonctionne normalement, puis ensuite un autre rendu avec un ou deux effets pris en charge par Cuda et d'origine de Premiere.

    Prend une autre vidéo pour faire tes essais (2 minutes suffisent), ça sera plus simple que ton projet qui est vraiment complexe.
     
  14. Bibuus

    Points Repaire:
    550
    Recos reçues:
    0
    Messages:
    23
    Appréciations:
    +0 / 0 / -0
    Test fait !
    Les résultats sont pour le peu... surprenants.

    Le clip de test faisait 5minutes.

    H264 de Premier SANS effets : 3 min50
    H264 Voukoder SANS effets : 40 secondes
    H264 de Premier AVEC effets : 26 Minutes
    H264 Voukoder AVEC effets : 26 minutes

    Effets : Lumetri color et Transformation (de bases sur Premier)

    Mon GPU est passé pour la première fois à 90% d'utilisation uniquement lors du rendu SANS effets.
     
  15. MyPOV

    So

    Points Repaire:
    7 900
    Recos reçues:
    51
    Messages:
    4 071
    Appréciations:
    +252 / 637 / -4
    Donc la prise en charge de Voukoder fonctionne bien mais pas la prise en charge de Cuda par Premiere.
     
Chargement...

Dernières occasions

 

Partager cette page

Dernières Occasions

 
Vous souhaitez annoncer sur le Repaire ? Contactez-nous