Nous suivre

Programme simple pour une compression de qualité en AVCHD

Discussion dans 'Compressions conversions exports Mpeg, H264, AVCHD' créé par baloub, 17 Mars 2011.

  1. baloub

    So

    Points Repaire:
    6 230
    Recos reçues:
    85
    Messages:
    1 613
    Appréciations:
    +0 / 20 / -0
    A vrai dire, je n'ai plus la description de l'entête d'un AVI...
    Tout au plus on peut dire que l'un contient un flux audio (debugmode) et pas l'autre. Ou ce n'est pas présenté pareil.

    Que dit mediainfo ?

    Sinon, essai en forçant "tous formats" plutôt que "avi". Ca oblige Avisynth à utiliser DirectShowSource (on n'est malheureusement pas maître des filtres qui seront choisis) à la place d' "OpenDMLSource".
     
  2. ogt

    ogt
    Conseiller Technique So

    Points Repaire:
    17 200
    Recos reçues:
    500
    Messages:
    21 141
    Appréciations:
    +547 / 1 077 / -30
    "Sinon, essai en forçant "tous formats" plutôt que "avi"."

    Ca marche bien : plus d'erreur, ça va jusqu'au bout, y compris le muxage, mais
    il n'y a pas d'images dans le film crée : toutes les images sont grises (pas noires)

    J'ai l'impression qu'il y a un gros chisme avec Advanced frameserver.

    Donc je suis coincé, aucun des frameservers ne fonctionne de façon satisfaisante.

    Olivier
     
  3. ilya_fr

    Points Repaire:
    1 000
    Recos reçues:
    0
    Messages:
    145
    Appréciations:
    +0 / 1 / -0
    Bonjour Olivier,

    En marge de la discussion que je suis par ailleurs avec intérêt, je réagis à ton propos pour te demander s'il t'est possible, à toi ou à Baloub, de donner un lien permettant d'obtenir cette version de Cam2x264 ?
    Pour ma part, j'utilise la V.1.2.0.9 2011.05.17, en "tandem" avec DebugMode Frameserver à partir de Premiere Pro CS4, sans avoir de souci majeur.
    Toutefois certaines options de filtrage de Cam2x264 ne me semblent pas fonctionner, telle que le désentrelacement.
    Alors peut-être qu'une version plus récente de l'encodeur fera effet ?

    Merci !

    ILYA
     
  4. ogt

    ogt
    Conseiller Technique So

    Points Repaire:
    17 200
    Recos reçues:
    500
    Messages:
    21 141
    Appréciations:
    +547 / 1 077 / -30
    Les liens de téléchargement avaient été redonnés quelques post au dessus, je les rappelle :
    cam2x264.exe v1.2.0.9

    Correctif pour cam2x264

    Le problème que j'ai avec Debugmodeframeserver (one shot only) n'existe que depuis la version CS6, dû a un changement de structure du fichier projet de Premiere (problème identique avec le plugin Mainconcept codec suite 5.1, qui depuis a été corrigé par le plugin Rovi total code).

    Olivier
     
  5. baloub

    So

    Points Repaire:
    6 230
    Recos reçues:
    85
    Messages:
    1 613
    Appréciations:
    +0 / 20 / -0
    Olivier, pour ton problème avec "advanced frameserver", je pense qu'il s'agit d'une histoire de 32/64 bits.

    Je viens de faire un test avec CS6 et ce frameserver : le pseudo AVI est chargé dans virtualdub : pas de problème avec la version 64 bits, frames grises avec la version 32 bits (ou plutôt vertes).
    Idem dans Edius 6.08 : frames vertes

    Il faudrait une version 64 bits d'avisynth et des plugins également 64 bits (dont mvtools2).
    Ils existent mais il y a surement d'autres trucs à prendre en compte...

    Ilya, pour ce qui est de cam2x264 je pense en reprendre le suivit (pas très évident après deux ans d'arrêt). Il y aura sans doute plusieurs codec vidéo (x264 bien sûr mais aussi sa version "mpeg2" baptisé x262 et surtout le tout nouveau x265 qui génère de l' h265/hevc) ainsi que divers codecs audio (ac3, aac notamment).
     
  6. ogt

    ogt
    Conseiller Technique So

    Points Repaire:
    17 200
    Recos reçues:
    500
    Messages:
    21 141
    Appréciations:
    +547 / 1 077 / -30
    "Il faudrait une version 64 bits d'avisynth et des plugins également 64 bits (dont mvtools2).
    Ils existent mais il y a surement d'autres trucs à prendre en compte..."

    Merci je vais regarder de ce coté, mais je ne comprend pas pourquoi alors ça marche avec Debugmode frameserver, puisque ensuite les logiciels utilisés sont les mêmes dans les 2 cas.

    Outre le fait qu'il fonctionne en "one shot" c'est dommage aussi que debugmode frameserver ne prenne pas en compte l'audio en 5.1, ce qui m'oblige à faire 2 manip suppémentaires :
    - export de l'audio seule en PCM, 6 canaux (dans un AVI), puis extraction et conversion en AC3.

    Olivier
     
  7. ilya_fr

    Points Repaire:
    1 000
    Recos reçues:
    0
    Messages:
    145
    Appréciations:
    +0 / 1 / -0
    Bonsoir Olivier,

    Euh, excuse-moi, j'ai du mal m'exprimer... Le lien que tu donnes permet de télécharger la V1.2.0.9 de Cam2x264, OK, ce qui est la version que j'utilise.
    Dans un post précédent, tu mentionnais une version 1.2.11 de Cam2x264, et c'est celle-ci que je ne parviens pas à trouver sur le Web !
    Alors, si tu as le lien "qui va bien" pour cette version 1.2.11, je suis intéressé !

    Merci !

    ILYA
     
  8. ogt

    ogt
    Conseiller Technique So

    Points Repaire:
    17 200
    Recos reçues:
    500
    Messages:
    21 141
    Appréciations:
    +547 / 1 077 / -30
    C'est simplement le deuxième lien donné, qui n'est qu'un correctif, mais qui change le numéro de version.

    Olivier
     
  9. ilya_fr

    Points Repaire:
    1 000
    Recos reçues:
    0
    Messages:
    145
    Appréciations:
    +0 / 1 / -0
    Oh, désolé, je n'avais pas compris le rôle du 2ème lien... Merci Olivier !

    ILYA
     
  10. ilya_fr

    Points Repaire:
    1 000
    Recos reçues:
    0
    Messages:
    145
    Appréciations:
    +0 / 1 / -0
    Salut Baloub !

    Je te remercie d'autant plus de te relancer dans l'aventure, que je comprends bien que ça ne doit pas être facile de s'y remettre après coup !
    Très modestement car je ne suis pas du tout capable d'apporter une aide en terme de développement de ton logiciel, je te servirai de bêta testeur si cela peut t'être utile, ça au moins je devrais savoir faire...

    ILYA
     
  11. patso28

    Points Repaire:
    1 000
    Recos reçues:
    0
    Messages:
    174
    Appréciations:
    +0 / 0 / -0
    Bonjour,

    j'utilise ce sympathique logiciel depuis un moment pour compresser en sortie d'Edius.
    Dans ma dernière vidéo, j'ai du rogner dans "outil de présentation" dans Edius.
    Je me retrouve donc en 1920x1080 avec 2 bandes noires horizontales.

    Je voulais faire un vrai rognage avec Cam2x64 pour obtenir du 1920x1020.
    Je n'y arrive pas :unsure:

    Voici comment je procède:
    -J'ouvre la vidéo
    -je vais dans filtres, je lance virtualDub
    -Dans virtualDub, je vais dans filtres/nul transform/cropping et je valide
    -Je ne ferme pas virtualDub, je retourne dans cam2x64
    -je lance l'encodage...Au final, il y a toujours les bandes noires en 1920x1080.

    Si quelqu'un à une idée...merci d'avance
     
  12. baloub

    So

    Points Repaire:
    6 230
    Recos reçues:
    85
    Messages:
    1 613
    Appréciations:
    +0 / 20 / -0
    Bonjour,

    Une fois lancé, virtualdub devient autonome. Il n'a plus aucun lien avec cam2x264.
    Il ne sert qu'à contrôler l'effet des filtres internes à cam2x264.

    Pour rogner la vidéo il faudrait un filtre de cropping comme il existe un redimensionnement où la possibilité de modifier manuellement le script avisynth avant son exécution.

    Il n'y a pas de solution directe actuellement.

    La seule chose que tu puisses faire est, une fois virtualdub lancé, :
    - faire un rognage dans virtualdub
    - sauvegarder à partir de virtualdub un nouveau fichier AVI en utilisant le codec canopus dans virtualdub (ça marche bien)
    - mettre ce nouvel AVI dans cam2x264 et encoder en h264.
     
  13. patso28

    Points Repaire:
    1 000
    Recos reçues:
    0
    Messages:
    174
    Appréciations:
    +0 / 0 / -0
    Merci Baloub,

    J'ai suivi ton conseil, ca marche parfaitement :good:
    Jusqu'ici je sortais en MPEG2 50mb/s d'Edius, pour ce nouvel essai j'ai donc pris AVI avec le codec canopus lossless.
    Je ne sais pas si c'était nécessaire, le HQX ou HQ aurait peut-être été suffisant pour ensuite le passer dans cam2x64.
     
  14. baloub

    So

    Points Repaire:
    6 230
    Recos reçues:
    85
    Messages:
    1 613
    Appréciations:
    +0 / 20 / -0
    Je ne sais pas pourquoi tu dois prendre ce format mais tu peux le faire directement depuis edius. Dans la définition du projet il faut alors prendre le codec HQX au lieu du HQ car ce dernier est "strict" dans les dimensions.
    La qualité standard est suffisante.
    Tu peux alors exporter en AVI canopus HQX standard 1920x1020 et encoder ensuite dans cam2x264.

    En export, même si ça prend un peu plus de place, il est préférable de prendre le codec canopus plutôt que le mpeg2 même à haut débit.
     
  15. patso28

    Points Repaire:
    1 000
    Recos reçues:
    0
    Messages:
    174
    Appréciations:
    +0 / 0 / -0
    Je prenais le MPEG2 car je pensais qu'il était mieux grâce à son débit important...
    Je vais changer ca pour mes prochains montages :jap:
     
Chargement...

Partager cette page

Autres contenus

Vous souhaitez annoncer sur le Repaire ? Contactez-nous