Nous suivre

  1. Découvrez notre vidéo de formation / test sur la Canon XF705 !
    Son capteur, son codec H265, son autofocus, ses gammas, le C-Log3, ses forces et ses limites, vous saurez tout ! Toutes les infos

    Rejeter la notice

Lecture Blu-Ray saccadée

Discussion dans 'Gravure DVD – Blu-Ray' créé par Hawk-Eye, 9 Novembre 2016.

  1. ogt

    ogt
    Conseiller Technique So

    Points Repaire:
    17 200
    Recos reçues:
    490
    Messages:
    20 552
    Appréciations:
    +516 / 1 023 / -30
    inspirez vous de ce tuto pour faire des chapitres dans un montage AVCHD :
    Création de chapitres dans une vidéo | Le Repaire

    Olivier
     
    #16 ogt, 12 Novembre 2016
    Dernière édition: 12 Novembre 2016
  2. arnuche

    Points Repaire:
    3 470
    Recos reçues:
    7
    Messages:
    1 236
    Appréciations:
    +1 / 8 / -1
    Il faut faire ça avec tsMuxer et c'est très simple, il y a un onglet Blu-ray dans lequel on peut rajouter des chapitres (ça marche aussi pour les AVCHD).
    Tu exportes au format AVCHD folder ; tu choisis un dossier dans lequel il créera 2 sous-dossiers ; BDMV et CERTIFICATE. Tu peux graver les 2 en mode UDF 2.50 (par exemple avec ImgBurn qui est gratuit et très complet) sur dvd ou BD-R (donc les 2 dossiers à la racine du disque, pas en tant que sous-dossiers d'un dossier principal).
    Mais tsMuxer n'autorise qu'un seul titre, donc si tu as plusieurs fichiers, soit tu les colles (tu les importes en cliquant sur join à condition qu'ils aient les mêmes caractéristiques ; réso, framerate, piste audio ...), soit tu utilises MultiAVCHD qui permet plus de choses mais qui n'est plus mis à jour depuis des années.
    Tu peux aussi mettre les 2 dossiers sur disque dur externe ou clé usb dans un dossier nommé AVCHD (si ton lecteur gère l'AVCHD sur ces supports), mais il faut voir s'il gère le ntfs ou seulement le fat32. Dans ce cas il faut activer la découpe dans tsMuxer (split by size every 3,99 GiB), la découpe ne se verra pas à la lecture.
    Pas besoin de découpe si c'est pour une gravure sur dvd ou BD-R grâce au mode UDF 2.50. Tu peux même graver un seul fichier de 8 Go sur dvd-9, il le coupera en 2 sans qu'il n'y ait de coupure visible à la lecture (et si plus tard on veut le recopier sur disque dur à partir du dvd-9, un simple drag&drop suffit, ça redeviendra un seul fichier).
    Fais quand-même gaffe au débit si c'est pour un dvd, au-dessus de 30 Mbps ça pourrait coincer (j'ai testé du 28 Mbps sur dvd+rw sans souci).
     
    • Merci Merci x 1
  3. Hawk-Eye

    Points Repaire:
    750
    Recos reçues:
    1
    Messages:
    44
    Appréciations:
    +0 / 0 / -0
    Bonjour,

    J'ai pu tester ce matin tsMuxeR. Malheureusement, j'ai un message d'erreur dès lors que je clique sur "Start Muxing" après avoir renseigné mon fichier initial (et sans chapitre ici). Le voici :
    upload_2016-11-14_9-19-41.png
    Ai-je oublié quelque chose ?

    Merci
     
  4. arnuche

    Points Repaire:
    3 470
    Recos reçues:
    7
    Messages:
    1 236
    Appréciations:
    +1 / 8 / -1
    Je vois qu'il y a du aac pour l'audio, ce n'est pas compatible AVCHD, il faut le convertir d'abord en ac3 ou dts (ou pcm) ou encore dd+ (e-ac3), par exemple avec eac3to ou ffmpeg.
    Je peux t'expliquer si tu ne sais pas comment faire.
     
  5. Hawk-Eye

    Points Repaire:
    750
    Recos reçues:
    1
    Messages:
    44
    Appréciations:
    +0 / 0 / -0
    Merci pour l'info. Du coup, même après conversion en ac3, j'ai le même message d'erreur. :weird:
     
  6. arnuche

    Points Repaire:
    3 470
    Recos reçues:
    7
    Messages:
    1 236
    Appréciations:
    +1 / 8 / -1
    Bizarre, le dossier n'est pas protégé ? Il y a assez de place sur cette partition ?
     
  7. Hawk-Eye

    Points Repaire:
    750
    Recos reçues:
    1
    Messages:
    44
    Appréciations:
    +0 / 0 / -0
    J'ai trouvé ! Visiblement, tsMuxeR n'aime pas les noms de dossier avec des espaces. Ma variable d'environnement %temp% possède un espace " " normal, mais lui l'a transcrit en "_" (dans "Temporary_Files"). Du coup, il ne trouvait pas de tel dossier... Et maintenant ça fonctionne !

    Pour ce qui est de l'audio en AAC, je suis obligé de le convertir ? Si oui, je veux bien de l'aide comme tu m'as proposé... :unsure:
     
  8. ogt

    ogt
    Conseiller Technique So

    Points Repaire:
    17 200
    Recos reçues:
    490
    Messages:
    20 552
    Appréciations:
    +516 / 1 023 / -30
    NON, ça marche très bien avec l'audio en AAC, qui est aussi accepté dans le format AVCHD (mais pas en Blu-ray)
    => TS muxer sort une message d'erreur, mais génère bien le dossier.

    olivier
     
  9. arnuche

    Points Repaire:
    3 470
    Recos reçues:
    7
    Messages:
    1 236
    Appréciations:
    +1 / 8 / -1
    Ben oui tu es obligé puisque ce n'est pas compatible, pas le choix.

    Mais tu disais plus haut avoir déjà converti en ac3 :perplexe:

    Il y a plusieurs méthodes, en voici une avec ffmpeg (en ligne de commande) ;
    -le prendre là ;
    Builds - Zeranoe FFmpeg
    -l'installer de cette manière ;
    Installer ffmpeg sous Windows et Mac
    -tu ouvres l'invite de commande de Windows
    -tu tapes ce genre de commande ;
    Code:
    ffmpeg -i "H:\ma vidéo.mkv" -vn -c:a ac3 -b:a 448k "P:\mon ac3 48khz.ac3"
    -b:a 448k c'est pour bitrate audio de 448 kbps, tu peux mettre moins (384, 320, 224, ...).

    S'il y a plusieurs pistes audio, tu analyses ta vidéo avec une commande de ce genre (sans option derrière l'input) ;
    Code:
    ffmpeg -i "H:\ma vidéo.mkv"
    -tu repères le n° de la piste audio en question (ça commence en général à 0:1 pour le son, il est mis Stream #0:1 suivi de détails) et tu rajoutes -map 0:1 (ou -map 0:2 ...) à la fin des options ;
    Code:
    ffmpeg -i "H:\ma vidéo.mkv" -vn -c:a ac3 -b:a 448k -map 0:1 "P:\mon ac3 48khz.ac3"
    Pour un AVCHD, il faut bien sûr une fréquence de 48 khz ou un de ses multiples (on peut voir ça avec MediaInfo). Donc si on part d'une autre fréquence (genre 44,1), on peut rajouter -ar 48000 ;
    Code:
    ffmpeg -i "H:\ma vidéo.mkv" -vn -c:a ac3 -ar 48000 -b:a 448k -map 0:1 "P:\mon ac3 48khz.ac3"
    Ensuite tu ouvres ton mkv dans tsMuxer, tu décoches la piste aac, tu ouvres l'ac3 et tu lances l'export.
     
  10. arnuche

    Points Repaire:
    3 470
    Recos reçues:
    7
    Messages:
    1 236
    Appréciations:
    +1 / 8 / -1
    Ça passera peut-être sur pc mais pas sur lecteur de salon.
     
  11. Hawk-Eye

    Points Repaire:
    750
    Recos reçues:
    1
    Messages:
    44
    Appréciations:
    +0 / 0 / -0
    En fait, j'ai tout simplement testé avec un fichier où l'audio était en ac3, mais pour mon fichier que je cherche à graver sur BDR, l'audio est toujours en ACC.

    C'est exactement ce que je me demandais. Car j'ai essayé avec AAC, et ça a fonctionné malgré une alerte comme l'a dit ogt. Du coup, c'est lu sur PC mais si sur lecteur de salon ça ne fonctionne pas, alors je vais convertir l'audio en AC3 car le lecteur salon est ma finalité. Merci pour les explications, je vais les étudier et tester. :bravo:
     
  12. Hawk-Eye

    Points Repaire:
    750
    Recos reçues:
    1
    Messages:
    44
    Appréciations:
    +0 / 0 / -0
    Bonjour,

    Me revoilà ! Pas de soucis pour convertir l'audio en ac3.

    J'ai acheté la plateforme BluRay Player Samsung BD-J4500R, compatible AVCHD.
    J'ai suivi scrupuleusement toutes les étapes que tu m'as indiquées (tsMuxeR, imgBurn) mais la lecture ne fonctionne pas et s'arrête dès que je la lance. Avez-vous une idée ? A cause de 50p ? Bitrate trop important ? Autre ?

    Merci
     
  13. ogt

    ogt
    Conseiller Technique So

    Points Repaire:
    17 200
    Recos reçues:
    490
    Messages:
    20 552
    Appréciations:
    +516 / 1 023 / -30
    Certainement, il suffit de regarder les spécifications de ce matériel (voir image)

    PS : l'AAC est bien accepté en encodage MP4, et lu par ce lecteur.

    Olivier
     

    Fichiers attachés:

  14. Hawk-Eye

    Points Repaire:
    750
    Recos reçues:
    1
    Messages:
    44
    Appréciations:
    +0 / 0 / -0
    Bizarre, car si je ne grave que le fichier *.mts du dossier STREAM (donc pas de structure AVCHD) la lecture du fichier fonctionne...
     
  15. arnuche

    Points Repaire:
    3 470
    Recos reçues:
    7
    Messages:
    1 236
    Appréciations:
    +1 / 8 / -1
    Et il reconnaît au moins le disque comme un AVCHD ? Si non, c'est peut-être lié aux dossiers créés par tsMuxer.
    Et si oui, il faudrait tenter avec de l'entrelacé pour voir si ça passe.
     
Chargement...

Partager cette page

Autres contenus

Vous souhaitez annoncer sur le Repaire ? Contactez-nous