module inscription newsletter haut de page forum mobile

[CommentFaire?] Enlever le "fond noir automatique" derrière une image/un plan

Discussion dans 'Blackmagic DaVinci Resolve' créé par EraldLawliet, 24 Octobre 2020.

  1. EraldLawliet

    Points Repaire:
    550
    Recos reçues:
    0
    Messages:
    18
    Appréciations:
    +0 / 0 / -0
    Hello,

    Alors voilà, lorsque j'insère un plan dans la timeline, en l'occurrence une image PNG, si celle-ci n'est pas à la même résolution que le projet, alors Da Vinci "comble" l'espace vide avec du noir.

    Or, j'aimerais simplement que ce noir disparaisse et laisse transparaitre le plan du dessous.

    Petit screen pour que ça soit plus clair :
    aide da vinci 0.png

    Dés que je baisse le zoom, le plan d'en dessous apparaît comme par magie, mais si le zoom est paramétrer à 100% ou plus, le "fond noir" apparait automatiquement :
    aide da vinci 1.png

    Comment faire pour moduler ce fond noir ? Choisir la transparence, ou même une autre couleur à la place de ce fond noir ?
     
  2. Le phoque

    Points Repaire:
    1 300
    Recos reçues:
    2
    Messages:
    129
    Appréciations:
    +2 / 6 / -0
    Bonjour

    Utilise la fonction Rognage
     
  3. EraldLawliet

    Points Repaire:
    550
    Recos reçues:
    0
    Messages:
    18
    Appréciations:
    +0 / 0 / -0
    Alors le problème c'est que dés lors que j'utilise le rognage, le fond noir disparait mais le rognage s'applique sur mon image (la photo) car le fond noir n'existe pas sur mon image d'origine, c'est Da Vinci qui l'applique autour pour "combler le vide". Dans l'absolu, comme vu dans mon deuxième screen, il suffit que je modifie légèrement un paramètre et le fond disparait, mais cela m'ennuie de devoir soit appliquer une légère rotation, un zoom, etc.
    D'ailleurs, si j'augmente le zoom, le noir ne s'enlève pas, c'est uniquement quand je diminue le zoom...

    Faites le test sur votre propre ordi et dites moi si ça vous fait pareil...

    Il doit bien y avoir un moyen de choisir que le fond noir ne s'applique pas, non ?
     
  4. gophoto

    Points Repaire:
    550
    Recos reçues:
    0
    Messages:
    30
    Appréciations:
    +2 / 0 / -0
    Bonjour. fait un détourage sur Photoshop et enregistre ton image, avec le fond transparent, en PNG
     
  5. EraldLawliet

    Points Repaire:
    550
    Recos reçues:
    0
    Messages:
    18
    Appréciations:
    +0 / 0 / -0
    Bonjour, vous n'avez pas compris :
    mon image n'a absolument AUCUN fond noir, c'est da vinci qui rajoute le noir pour combler le vide.

    J'explique bien (avec mon deuxième screen) qu'en modifiant un paramètre comme le zoom, le fond noir disparait. C'est un bug d'affichage ou un paramètre automatique qui dit que dés lors qu'une image n'a pas la même résolution que le projet, alors da vinci ajoute du noir...

    Mais je n'ai aucune idée de comment modifier ça
     
  6. gophoto

    Points Repaire:
    550
    Recos reçues:
    0
    Messages:
    30
    Appréciations:
    +2 / 0 / -0
    Bien sûr c'est normal puisqu'il n'y a pas de matière. Redimenssione ton image au bon format sous Photoshop. Bon courage
     
  7. EraldLawliet

    Points Repaire:
    550
    Recos reçues:
    0
    Messages:
    18
    Appréciations:
    +0 / 0 / -0
    Mon but n'est pas d'avoir une image au bon format... Auquel cas je la redimensionnerai directement dans Da Vinci avec l'outil zoom...

    Ce que je veux c'est superposer les 2 plans, avec le plan du dessus qui laisse apparaitre le plan du dessous, donc y'a rien à redimensionner sur Photoshop, y'a juste à faire en sorte que Da Vinci ne mettent pas un fond noir sans raison.

    J'ai trouvé une astuce qui fonctionne (même si c'est pas idéal), si je change l'opacité (ou tout autre paramètre : angle, rognage, position x/y) et que je la met à 99,99%, le fond noir disparait. Mais bon c'est du bidouillage, je suis sûr que y'a un paramètre fait pour.

    Mais bref ça m'ira pour le moment, mais si quelqu'un a la vrai solution, je suis preneur.

    Merci à tous.
     
  8. Alcoriza

    So So

    Points Repaire:
    5 800
    Recos reçues:
    71
    Messages:
    3 434
    Appréciations:
    +171 / 302 / -1
    Clic droit sur ta photo / clip attributes / Alpha mode : premultiplé et ça vire ton fond noir
     
  9. EraldLawliet

    Points Repaire:
    550
    Recos reçues:
    0
    Messages:
    18
    Appréciations:
    +0 / 0 / -0
    Hello Alcoriza,
    c'est effectivement une des solution que je pensais avoir trouvé, seulement :
    ça enlève aussi certains pixels noir dans mon image :
    aide da vinci 2.png
     
  10. samalaplaya

    Points Repaire:
    3 530
    Recos reçues:
    22
    Messages:
    409
    Appréciations:
    +17 / 39 / -0
    Bonjour

    Est-ce que si tu changes la taille de zoom tu retrouves ton alpha ?
    Est-ce que si tu vas dans la page color > clic droit dans le node flow : "add alpha output" > tu connectes ton alpha de png (bleu) à l'ouput alpha, tu retrouves ton alpha ?
     
  11. Le phoque

    Points Repaire:
    1 300
    Recos reçues:
    2
    Messages:
    129
    Appréciations:
    +2 / 6 / -0
    Bonjour

    Voici une méthode qui fonctionne. Tu sélectionne ton élément, Clique droit de la souris et tu choisis " Open in Fusion Page" (image 1).

    Par la suite tu crées une composition tel qu'illustré dans l'image 2 en prenant soins de mettre le canal Alpha du Background à zéro.

    Le phoque
     

    Fichiers attachés:

  12. samalaplaya

    Points Repaire:
    3 530
    Recos reçues:
    22
    Messages:
    409
    Appréciations:
    +17 / 39 / -0
    Hello,
    Bon, tu n'as pas répondu, mais anyway il s'agit certainement pour le coup d'un réel bug.
    Le plus simple pour le contourner est probablement de changer les "input settings" dans les paramètres du projet.
    Par ex. si tu mets "center crop with no resizing" ça devrait être ok...
     
  13. Le phoque

    Points Repaire:
    1 300
    Recos reçues:
    2
    Messages:
    129
    Appréciations:
    +2 / 6 / -0
    Bonjour

    J'ai fait quels tests et voici ce que j'ai pu remarquer, cela sans comprendre la logique.

    Je place sur vidéo 1 un élément de 1920X1080, je place sur la piste vidéo 2 une image de 500X625. À la sortie je me retrouve avec des bordures noires (Image 01).

    En prenant sois de sélectionner mon image de 500X625, je vais dans fusion. Dans celui-ci j'insère un background sans l'unir à aucun autre noeud (Image 02). Je décoche Auto Resolution et je dimensionne celui-ci au dimension de mon projet 1920X1080 (Image 03).

    Je retourne dans mon onglet montage et je retrouve mon image de 500X625 sans bordure noire (Image 04).

    Trouvez l'erreur !

    Bon montage

    Le phoque
     

    Fichiers attachés:

Chargement...

Partager cette page

Dernières Occasions

Dernières Formations

 
Vous souhaitez annoncer sur le Repaire ? Contactez-nous