Nous suivre

  1. Découvrez notre vidéo de formation / test sur la Canon XF705 !
    Son capteur, son codec H265, son autofocus, ses gammas, le C-Log3, ses forces et ses limites, vous saurez tout ! Toutes les infos

    Rejeter la notice

[Tuto] Encodage Premiere en X264 x265, Nvidia ou AMD, VBR, CQP, AC3, MKV etc

Discussion dans 'Compressions conversions exports Mpeg, H264, AVCHD' créé par MyPOV, 18 Mars 2018.

Tags:
  1. ogt

    ogt
    Conseiller Technique So

    Points Repaire:
    17 200
    Recos reçues:
    490
    Messages:
    20 557
    Appréciations:
    +516 / 1 024 / -30
    Pour le moment, Staxrip est beaucoup plus paramétrable que le pluging voukoder, toutes les options de x264 et x265 y sont disponibles, et le choix d'options (formats) de sortie est beaucoup plus vaste, mais c'est moins pratique à utiliser qu'un simple plugin.
    Pour info : il y a une version récente (Sep 23 2017) de Starip, la 1.7.0

    Olivier
     
  2. hola

    Points Repaire:
    4 180
    Recos reçues:
    23
    Messages:
    3 803
    Appréciations:
    +40 / 142 / -4
    caraibe

    StaxRip et Frameserver ne fonctionnent pas avec un GPU AMD (Radeon RX 4xx ...RX 5xx )

    donc ce pluging voukoder est intéressant ..
     
  3. ogt

    ogt
    Conseiller Technique So

    Points Repaire:
    17 200
    Recos reçues:
    490
    Messages:
    20 557
    Appréciations:
    +516 / 1 024 / -30
    Je pense que si, avec la dernière version 1.7.0, mais n'ayant pas de carte graphique AMD, je ne peux pas tester.

    Olivier
     

    Fichiers attachés:

  4. caraibe

    So

    Points Repaire:
    13 400
    Recos reçues:
    154
    Messages:
    14 399
    Appréciations:
    +167 / 641 / -13
    Le plug voukoder n'est pas pris en compte chez moi par CC2015.1 bizarre !!!!
     
    #49 caraibe, 20 Mars 2018
    Dernière édition: 20 Mars 2018
  5. hola

    Points Repaire:
    4 180
    Recos reçues:
    23
    Messages:
    3 803
    Appréciations:
    +40 / 142 / -4
    ogt

    la version 1.7.0 fonctionne effectivement très bien avec ma Radeon RX 460 ( la vitesse d’exécution est bluffante ) mais avec un fichier .avi style cineform ou canopus..

    par contre sortie vegas avec le Frameserver Staxrip ne veut rien savoir..
     
  6. MyPOV

    So

    Points Repaire:
    9 400
    Recos reçues:
    54
    Messages:
    4 577
    Appréciations:
    +275 / 681 / -4
    Après avoir filmé cet après-midi, une première vidéo HD1080 sortie avec la partie Nvidia264, la vidéo est entièrement stabilisée, avec Lumetri et des sources en 2304x1296. Preset en Slow et qualité QP sur 17 pour avoir un très bon rendu. Pendant l'exportation, le CPU est entre 70 et 90%, le GPU entre 70 et 90%, et le Video Engine autour de 19% pour du 40ips. Je pense que mon CPU ne me permet pas d'avoir plus, mais cela me convient, ça rend tout de même l'encodage plaisant avec une vitesse satisfaisante et une méthode basée sur une qualité fixe.

    Comme je l'espérais pour une méthode avec un Constant Quantizer, la répartition des données est efficace entre les plans presque fixes et ceux animés, notamment sur le générique final.
    a_1.jpg

    @caraibe, tu es sûr de toi pour l'emplacement du fichier Voukoder.prm ? Dans quel dossier l'as-tu déposé ?
     
    #51 MyPOV, 21 Mars 2018
    Dernière édition: 21 Mars 2018
  7. ogt

    ogt
    Conseiller Technique So

    Points Repaire:
    17 200
    Recos reçues:
    490
    Messages:
    20 557
    Appréciations:
    +516 / 1 024 / -30
    On a essayé tous les emplacements possibles, par téléphone
    - plugins commons à Premiere et Aftereffects (c'est là ou moi je l'ai mis, pour qu'il soit pris aussi par MediaEncoder)
    - plugins commons de Premiere
    - plugins fr-FR de Premiere
    La Log indique un message d'erreur (je ne l'ai plus en tête) au chargement du plugin
    Ca semble être une incompatibilité avec la CC2015.1 (moi j'ai la CC2015.2 et .4)

    Olivier
     
  8. MyPOV

    So

    Points Repaire:
    9 400
    Recos reçues:
    54
    Messages:
    4 577
    Appréciations:
    +275 / 681 / -4
    Ça serait a remonter comme information, mais j'imagine d'avance que la réponse va être de faire une mise à jour ce qui me semble normal, je suis en 2015.4. Peut-être que c'est un des points corrigés sur les versions suivantes à la 2015.1
     
  9. caraibe

    So

    Points Repaire:
    13 400
    Recos reçues:
    154
    Messages:
    14 399
    Appréciations:
    +167 / 641 / -13
    Je pense aussi que ça vient d'une incompatibilité avec la version CC 2015.1
    Ou alors je suis sous Seven d'origine même pas pack 2 ..:unsure:
     
  10. MyPOV

    So

    Points Repaire:
    9 400
    Recos reçues:
    54
    Messages:
    4 577
    Appréciations:
    +275 / 681 / -4
    Pareil, je suis en W7 sp1 avec des correctifs en plus, mais je doute que cela vienne de là sur le simple fait de ne rien voir dans Premiere. Éventuellement peut-être que cela vient de l'absence des librairies Microsoft Visual C++, tu les as toutes d'installées ? Est-ce que tu as d'autres codecs externes à Premiere qui fonctionnent dans Premiere, genre Logarith ?
     
  11. MyPOV

    So

    Points Repaire:
    9 400
    Recos reçues:
    54
    Messages:
    4 577
    Appréciations:
    +275 / 681 / -4
    J'ai poursuivi mes tests, il y a des choses qui dysfonctionnent par exemple en x265 la méthode Constant Quantizer ne fonctionne pas, quelque soit sa valeur on obtient la même vidéo de mauvaise qualité, par contre la méthode Constante Rate Factor fonctionne très bien. La qualité/taille du x264 et du Nvidia264 sont proches avec l'avantage de la vitesse pour le second. Le Nvidia265 avec la GTX960 n'a pas d’intérêt parce qu'il n'est pas complet de la part de Nvidia, donc la compression en pâti au point d'être moins bonne que le Nvidia264, il est possible que ce soit différent avec la série des GTX10xx.
     
    #56 MyPOV, 21 Mars 2018
    Dernière édition: 21 Mars 2018
  12. ogt

    ogt
    Conseiller Technique So

    Points Repaire:
    17 200
    Recos reçues:
    490
    Messages:
    20 557
    Appréciations:
    +516 / 1 024 / -30
    Je n'ai pas encore fait des tests exhaustifs, mais il y a beaucoup de paramètres qui ne fonctionnent pas, et génèrent une erreur au lancement. J'essayerai d'en faire un récapitulatif prochainement.
    En export Nvidia x264, j'obtiens une image correcte avec un Preset Slow et Quantizer à 21, et en réduisant la taille du Gop (30), je n'ai pas réussi à modifier les autres paramètres (en particullier pour la prédiction de mouvements), car ça se traduit par des erreurs.
    J'ai donc encodé mon film de 1h 28 en 3H, alors que Premiere mettait un peu plus de 5H (j'ai beaucoup d'effets en particulier Mercalli sur tous les clips).

    Olivier
     
    • Merci Merci x 1
  13. MyPOV

    So

    Points Repaire:
    9 400
    Recos reçues:
    54
    Messages:
    4 577
    Appréciations:
    +275 / 681 / -4
    Pour Mercalli tu fais des rendus à l'avance ou tout est calculé pendant l'encodage ? Mes stabilisations sont toujours calculées à l'avance parce que je peux avoir besoin d'en ajuster un paramètre pour le cadrage sur certains passages.

    J'ai beaucoup testé par le passé les méthodes et les paramètres à base de Quantizer avec MeGUI et x264, au final j'ai adopté la valeur de 20 (et Faster quand il est disponible) qui est bonne dans toutes les situations. Avec 17 j'ai une très bonne vidéo mais elle est nettement plus grande, je peux l'adopter par exemple pour un envoie sur Youtube.
     
  14. ogt

    ogt
    Conseiller Technique So

    Points Repaire:
    17 200
    Recos reçues:
    490
    Messages:
    20 557
    Appréciations:
    +516 / 1 024 / -30
    J'ai choisi 21 pour ne pas avoir une taille plus grande que l'export Mainconcept, l'image semble correcte, je n'ai pas fait de comparaison extrêmement précise sur la qualité.
    Pour Mercalli, je l'applique maintenant systématiquement sur tous les plans (pour avoir un rendu homogène) et j'applique aussi une netteté à 10, ce qui me donne une qualité d'image visuellement pratiquement identique à l'original (bien que légèrement zoomée, mais moins de 10%).
    J'ai pratiquement la lecture en temps réel dans Premiere donc inutile de faire des rendus, donc c'est à l'export que les calculs se font.

    Olivier
     
  15. MyPOV

    So

    Points Repaire:
    9 400
    Recos reçues:
    54
    Messages:
    4 577
    Appréciations:
    +275 / 681 / -4
    Je viens de tester tous les Presets pour le Nvidia264 avec la méthode Constant Quantizer, par contre c'est avec une GTX960 donc il est possible que le codec Nvidia soit différent avec une carte de la série GTX10xx.

    Avec la GTX960, plusieurs presets donnent exactement le même résultat à l'octet près.

    Normalement le Preset n'influence pas la qualité mais la compression (et l’optimisation de l'accès au flux pour une mise sur serveur) en passant plus ou moins de temps à l'analyse de l'image. Dans la pratique avec un vrai projet, mon CPU sature avec l'analyse du rendu est la partie compression hard 264 de la Nvidia n'est pas à pleine charge ce qui ne me permet pas de constater des différence de temps entre les presets.

    Enfin, j'ai vérifié la qualité visuel entre le preset par défaut (ou Lowlatency) et Slow : A la lecture il est impossible de détecter une différence, il faut analyser des captures d'écran pendant plusieurs minutes pour détecter un soupçon de mieux pour le preset Slow.

    b Nvidia264 preset.png
     
    #60 MyPOV, 22 Mars 2018
    Dernière édition: 22 Mars 2018
Chargement...

Partager cette page

Autres contenus

Vous souhaitez annoncer sur le Repaire ? Contactez-nous