Nous suivre

  1. Atelier Caméras RED - 16 & 17 octobre à Paris
    COMPLET !! Inscrivez-vous pour être informé des prochaines dates !
    Toutes les infos

    Rejeter la notice
  2. Découvrez notre vidéo de formation / test sur la Canon XF705 !
    Son capteur, son codec H265, son autofocus, ses gammas, le C-Log3, ses forces et ses limites, vous saurez tout ! Toutes les infos

    Rejeter la notice

différence entre ces 2 fichiers ? L'un passe au montage l'autre non

Discussion dans 'Autres logiciels de montage' créé par laurentj1982, 20 Avril 2018.

Tags:
  1. laurentj1982

    Points Repaire:
    1 650
    Recos reçues:
    1
    Messages:
    716
    Appréciations:
    +2 / 3 / -1
    Bonjour,
    j'essaie de résoudre un problème de montage vidéo sur Végas Pro.
    Les fichiers encodés sous OBS passe mal à la prévisualisation (affichage noire à chaque lecture pendant presque 1 sec).

    Voici les caractéristiques d'un fichier encodé par OBS :
    Code:
    Général
    Nom complet                              : C:\2018-04-19 11-32-58.mp4
    Format                                   : MPEG-4
    Profil du format                         : Base Media
    Identifiant du codec                     : isom (isom/iso2/avc1/mp41)
    Taille du fichier                        : 284 Mio
    Durée                                    : 1 min 16s
    Type de débit global                     : Constant
    Débit global moyen                       : 29,4 Mb/s
    Application utilisée                     : Lavf57.84.100
    
    Vidéo
    ID                                       : 1
    Format                                   : AVC
    Format/Info                              : Advanced Video Codec
    Profil du format                         : Main@L4.1
    Paramètres du format                     : CABAC / 3 Ref Frames
    Paramètres du format, CABAC              : Oui
    Paramètres du format, RefFrames          : 3 images
    Identifiant du codec                     : avc1
    Identifiant du codec/Info                : Advanced Video Coding
    Durée                                    : 1 min 16s
    Type de débit                            : Constant
    Débit                                    : 28,0 Mb/s
    Largeur                                  : 1 920 pixels
    Hauteur                                  : 1 080 pixels
    Format à l'écran                         : 16/9
    Type d'images/s                          : Constant
    Images par seconde                       : 30,000 Im/s
    Espace de couleurs                       : YUV
    Sous-échantillonnage de la chrominance   : 4:2:0
    Profondeur des couleurs                  : 8 bits
    Type de balayage                         : Progressif
    Bits/(Pixel*Image)                       : 0.450
    Taille du flux                           : 30,6 Mio (99%)
    
    Audio
    ID                                       : 2
    Format                                   : AAC
    Format/Info                              : Advanced Audio Codec
    Profil du format                         : LC
    Identifiant du codec                     : mp4a-40-2
    Durée                                    : 1 min 16s
    Type de débit                            : Constant
    Débit                                    : 161 kb/s
    Canaux                                   : 2 canaux
    Position des cannaux                     : Front: L R
    Echantillonnage                          : 44,1 kHz
    Images par seconde                       : 43,066 Im/s (1024 SPF)
    Mode de compression                      : Avec perte
    Taille du flux                           : 172 Kio (1%)
    Titre                                    : Track1
    Default                                  : Oui
    AlternateGroup/String                    : 1
    


    Le même fichier ré encodé avec Adobe Media Encoder passe parfaitement :
    Code:
    Général
    Nom complet                              : 2018-04-17 19-44-36_1-principal.mp4
    Format                                   : MPEG-4
    Profil du format                         : Base Media / Version 2
    Identifiant du codec                     : mp42 (mp42/mp41)
    Taille du fichier                        : 298 Mio
    Durée                                    : 1 min 16s
    Type de débit global                     : Variable
    Débit global moyen                       : 32,5 Mb/s
    Date d'encodage                          : UTC 2018-04-19 08:50:23
    Date de marquage                         : UTC 2018-04-19 08:50:28
    TIM                                      : 00:00:00:00
    TSC                                      : 30
    TSZ                                      : 1
    
    Vidéo
    ID                                       : 1
    Format                                   : AVC
    Format/Info                              : Advanced Video Codec
    Profil du format                         : Main@L4.2
    Paramètres du format                     : CABAC / 4 Ref Frames
    Paramètres du format, CABAC              : Oui
    Paramètres du format, RefFrames          : 4 images
    Paramètres du format, GOP                : M=4, N=30
    Identifiant du codec                     : avc1
    Identifiant du codec/Info                : Advanced Video Coding
    Durée                                    : 1 min 16s
    Débit                                    : 32,3 Mb/s
    Largeur                                  : 1 920 pixels
    Hauteur                                  : 1 080 pixels
    Format à l'écran                         : 16/9
    Type d'images/s                          : Constant
    Images par seconde                       : 30,000 Im/s
    Norme                                    : NTSC
    Espace de couleurs                       : YUV
    Sous-échantillonnage de la chrominance   : 4:2:0
    Profondeur des couleurs                  : 8 bits
    Type de balayage                         : Progressif
    Bits/(Pixel*Image)                       : 0.519
    Taille du flux                           : 296 Mio (99%)
    Langue                                   : Anglais
    Date d'encodage                          : UTC 2018-04-19 08:50:23
    Date de marquage                         : UTC 2018-04-19 08:50:23
    Gamme de couleurs                        : Limited
    Coordonnées de chromaticité              : BT.709
    Caractéristiques du transfert            : BT.709
    Coefficients de la matrice               : BT.709
    
    Audio
    ID                                       : 2
    Format                                   : AAC
    Format/Info                              : Advanced Audio Codec
    Profil du format                         : LC
    Identifiant du codec                     : mp4a-40-2
    Durée                                    : 1 min 16s
    Durée de la source duration              : 1 min 16s
    Type de débit                            : Variable
    Débit                                    : 192 kb/s
    Débit maximum                            : 248 kb/s
    Canaux                                   : 2 canaux
    Position des cannaux                     : Front: L R
    Echantillonnage                          : 48,0 kHz
    Images par seconde                       : 46,875 Im/s (1024 SPF)
    Mode de compression                      : Avec perte
    Taille du flux                           : 1,74 Mio (1%)
    Taille du flux source                    : 1,74 Mio (1%)
    Langue                                   : Anglais
    Date d'encodage                          : UTC 2018-04-19 08:50:23
    Date de marquage                         : UTC 2018-04-19 08:50:23
    
    
    Évidemment, il y a pas mal de différence entre ces 2 fichiers même si j'ai essayé de garder les même paramètres.
    Est-ce quelque chose peut expliquer que le 1er fichier ne passe pas et le 2ème si ? A première vue, j'aurais tendance à dire que le 2ème fichier est en "version 2" donc plus récent que le 1er.

    J'ai fait pas mal d'essai sur OBS en H264 sans succès (les paramètres ne sont pas légions).
    En revanche, en X264, cela semble marché ensuite sur Végas, mais des tests précédents montrait que sous OBS, lors de l'enregistrement, c'était moins stable.

    Merci d'avance pour tout conseil.
     
  2. saint kro

    saint kro Conseiller Technique Son numérique
    Modérateur So So

    Points Repaire:
    14 550
    Recos reçues:
    156
    Messages:
    16 496
    Appréciations:
    +251 / 1 283 / -27
    Deuxième ouverture de discussion portant sur le même sujet et postée n'importe où sauf dans la bonne section !

    Donc déplacé dans Vegas !
     
  3. laurentj1982

    Points Repaire:
    1 650
    Recos reçues:
    1
    Messages:
    716
    Appréciations:
    +2 / 3 / -1
    Le précédent dont j'ai demandé la suppression n'était pas dans la bonne section (erreur de ma part par rapport à l'heure tardive).

    Ce problème n'ayant aucun lien avec une fonctionnalité de Végas, je doute que quelqu'un réponde. C'est un problème d'encodage général qui peut intéresser tout utilisateur.

    A la limite, j'essaie dans d'autres logiciels de montage puis je republie ce sujet dans chaque section dédié à chaque logiciel de montage ?
     
  4. Alcoriza

    So

    Points Repaire:
    5 300
    Recos reçues:
    55
    Messages:
    2 357
    Appréciations:
    +88 / 147 / -0
    Ou alors tu mets en partage ton fichier pour qu'on regarde de notre côté...
     
  5. saint kro

    saint kro Conseiller Technique Son numérique
    Modérateur So So

    Points Repaire:
    14 550
    Recos reçues:
    156
    Messages:
    16 496
    Appréciations:
    +251 / 1 283 / -27
    Oui, il était dans une section généraliste, je l'ai mis dans "autres logiciels" puisque tu pars d'un fichier OBS, d'accord ?
    Là, tu le supprimes, on se demande pourquoi ?

    La logique veut que, si un fichier pose problème avec plusieurs lecteurs, il faut se demander pourquoi, et voir coté source et non du coté des différents lecteurs.

    En lisant ça, je suis enclin à déplacer dans Autres logiciels de montage

    Certainement pas !

    Tu confirmes que le souci est coté encodage OBS, donc retour section OBS...
     
  6. laurentj1982

    Points Repaire:
    1 650
    Recos reçues:
    1
    Messages:
    716
    Appréciations:
    +2 / 3 / -1
    Bonjour,
    le partager pour essayer dans un autre logiciel ? Ou pour l'"analyser" ?

    Car je pense que le problème vient surtout d'une config un peu légère au niveau de la carte graphique (une HD graphics 530).
    D'où mon interrogation sur ces 2 compressions H264 : le 2ème semble plus simple à traiter pour le logiciel, pourquoi ?
    cela ne vient pas du débit, ni de la définition ou de la fréquence d'image. Je m’aperçois même que le 2ème est en VBR ce qui est plus difficile à traiter que du CBR.

    Dans OBS, j'ai très peu de paramètres.
    Je peut partager le fichier si besoin dès que je l'aurais sous la main.

    Merci
     
  7. laurentj1982

    Points Repaire:
    1 650
    Recos reçues:
    1
    Messages:
    716
    Appréciations:
    +2 / 3 / -1
    Bonjour,
    voici le fichier encodé par OBS :
    Dropbox - encodageOBS.mp4

    et voici celui réencodé avec Media Encoder:
    Dropbox - reencodage Adobe.mp4

    Malgré des paramètres similaires (28 Mbit/s, CBR, AVCHD ...), celui encodé dans OBS passe mal au montage dans Végas. La previsualisation affiche du noir ou des taches noires pendant plus d'1 sec à chaque redémarrage de la lecture.

    J'aimerais comprendre ce qui, dans le peu de différence qu'ont ces 2 fichiers rends l'un plus difficile à monter.

    Merci
     
  8. ogt

    ogt
    Conseiller Technique So

    Points Repaire:
    17 200
    Recos reçues:
    500
    Messages:
    21 131
    Appréciations:
    +547 / 1 076 / -30
    J'ai téléchargé vos 2 fichiers :
    aucun problème de lecture sur Premiere Pro CC2017 et Vegas 14.
    Je pense que votre configuration peut être en cause, car le premier fichier est encodé au débit 28 Mbits/s, le second 4116 Kbits/s.
    Il est possible que vous ayez des problèmes d'accès disque.
    A voir avec le Moniteur de ressources de Windows : rubrique Disque, colonne temps de réponse.

    Olivier
     
  9. laurentj1982

    Points Repaire:
    1 650
    Recos reçues:
    1
    Messages:
    716
    Appréciations:
    +2 / 3 / -1
    En effet, le débit de 28 Mbits/ n'a pas été respecté par Media Encoder. J'ai essayé sur un autre PC et sur plusieurs disques et cela revient au même.

    De quoi ça peut venir à part un temps de réponse disque (qui a l'air correct sur le PC ou je viens de tester)?

    En effet, la config est à revoir, sur un autre PC je n'ai pas le problème de prévisualisation.

    Simplement, je m'interroge sur le fait qu'avec des paramètres équivalents, l'un des fichiers est lu parfaitement et l'autre non.
     
  10. ogt

    ogt
    Conseiller Technique So

    Points Repaire:
    17 200
    Recos reçues:
    500
    Messages:
    21 131
    Appréciations:
    +547 / 1 076 / -30
    Il suffit d'imposer le débit pour avoir le même que l'original, cela vous permettra de vraiment faire une vraie comparaison et de localiser le problème.

    olivier
     
  11. laurentj1982

    Points Repaire:
    1 650
    Recos reçues:
    1
    Messages:
    716
    Appréciations:
    +2 / 3 / -1
    En effet mais dans Media Encoder, j'ai bien réglé sur CBR et 28 Mbit/s. Du coup je suis perplexe.

    En plus, j'utilise ce logiciel très régulièrement et je ne pense pas me tromper.
     
  12. hola

    Points Repaire:
    4 180
    Recos reçues:
    23
    Messages:
    3 814
    Appréciations:
    +40 / 144 / -4
    les deux fichiers sont bien lisible* dans Vegas 13...comme expliqué plus haut par olivier

    *peut être une ou deux images noire avec le fichier encodé par OBS (vu en vitesse )
     
  13. Alcoriza

    So

    Points Repaire:
    5 300
    Recos reçues:
    55
    Messages:
    2 357
    Appréciations:
    +88 / 147 / -0
    Ça marche également avec Premiere Pro CC2018 sur PC et CC2017 sur Mac. On sent par contre sur mon vieux Mac Pro que ça rame un chouilla avec le fichier OBS ! T'as essayé d'enregistrer avec un container .mov ? De baisser le débit comme te l'as dit Ogt ?
     
  14. laurentj1982

    Points Repaire:
    1 650
    Recos reçues:
    1
    Messages:
    716
    Appréciations:
    +2 / 3 / -1
    Oui, j'ai essayé plusieurs débits, plusieurs conteneurs différents.... je pense que la manière dont travaille l'encodeur Quicksynth H264.

    J'ai trouvé cependant un solution en utilisant l'encodage x264. Là c'est lu sans (trop) de problème sur Végas. En revanche, c'est beaucoup plus lourd à encoder dans OBS mais paramétrant l'encodage sur "fastest", ça passe.

    Reste que je m'interroge de savoir pourquoi le fichier OBS est un peu plus dur à lire que celui de Première. Peut-être est-ce du au fait que l'encodage est en temps réel sur OBS ?

    Et je m'interroge encore plus sur Première qui me sort du 4 Mbit/s alors que je le paramètre sur 28 Mbits/s. C'est la première fois que je vois ça.
     
  15. ogt

    ogt
    Conseiller Technique So

    Points Repaire:
    17 200
    Recos reçues:
    500
    Messages:
    21 131
    Appréciations:
    +547 / 1 076 / -30
    Donnez une image de votre panneau de Paramétrage , mais si vous êtes en variable (VBR), vu que votre vidéo est essentiellement constituée d'images fixes, pas besoin d'un gros débit pour obtenir un bon résultat.

    Olivier
     
Chargement...

Partager cette page

Autres contenus

Vous souhaitez annoncer sur le Repaire ? Contactez-nous