Nous suivre

  1. Atelier Caméras RED - 16 & 17 octobre à Paris
    COMPLET !! Inscrivez-vous pour être informé des prochaines dates !
    Toutes les infos

    Rejeter la notice
  2. Découvrez notre vidéo de formation / test sur la Canon XF705 !
    Son capteur, son codec H265, son autofocus, ses gammas, le C-Log3, ses forces et ses limites, vous saurez tout ! Toutes les infos

    Rejeter la notice

[Problème] Convertir video MP4 (854*480) en TS (1024*576)

Discussion dans 'Les formats' créé par Basile, 26 Novembre 2017.

  1. Basile

    Points Repaire:
    1 000
    Recos reçues:
    0
    Messages:
    229
    Appréciations:
    +1 / 0 / -0
    Bonsoir

    J'ai enregitré un documentaire TV (.TS), avec mon magnétoscope. Malheureusement, ce dernier est parti trop tard :il me manque les 8 premières minutes de ce film (Film A).

    J'ai récupéré ce même film sur youtube en .MP4 et format d'image différent. J'en ai extrait les 8 premières minutes (film B)

    Mon but étant bien sûr de joindre A + B, dans une forme commune.

    Voici les caractéristiques de ces films, données par Mediainfo:

    Film A
    - Conteneur:MPEG-TS, 2,16Gio, 1Flux video AVC, 1 flux audio AAC
    - Première piste video: 1024x576, à 25 img/s, AVC(main@L3.1) (CABAC / 2 Ref Frames)
    - Première piste audio: 48,0 khz, 2 canaux, AAC (ADTS) (Version 4) (LC)

    Film B
    - Conteneur:MPEG-4 (Base Media), 39 Mio, 1Flux video AVC, 1 flux audio AAC
    - Première piste video: 854*480, à 25 img/s, AVC(main@L3) (CABAC / 3 Ref Frames)
    - Première piste audio: 126 kb/s, 44,1 khz, 2 canaux, AAC (LC)

    J'ai essayé de convertir B dans le format de A (pour garder la qualité TS le plus longtemps), avec les versions d'essai de Wondershare et d'Aiseesoft Converter sans succès, probablement à cause de ma méconnaissance de tous ces paramètres.Les données du fichier converti B ne correspondent pas aux données de A et il est impossible de les ajouter.

    Quelqu'un maîtrisant ces données pourrait-il me conseiller sur un logiciel et les différents paramètres?

    Je l'en remercie bien sincèrement par avance.
     
  2. MyPOV

    So

    Points Repaire:
    9 400
    Recos reçues:
    57
    Messages:
    4 794
    Appréciations:
    +290 / 705 / -4
    Bonsoir,

    Avant de chercher une solution, c'est en travaillant avec quel système, windows ?
     
  3. Basile

    Points Repaire:
    1 000
    Recos reçues:
    0
    Messages:
    229
    Appréciations:
    +1 / 0 / -0
    Avec mes plus plates excuses pour cet oubli: je suis sous Seven Pro ...
     
  4. MyPOV

    So

    Points Repaire:
    9 400
    Recos reçues:
    57
    Messages:
    4 794
    Appréciations:
    +290 / 705 / -4
    ça arrive à tout le monde :)

    Je tenterais la conversion avec avidemux qui permet d'exporter du TS.

    - ouvrir le petit bout de fichier de 8mn
    - sur la gauche à la sortie vidéo : Mpeg 4 AVC (x264), à l'onglet Frame, cocher la case CABAC
    - sur la gauche Filtre > Transformation > SWresize > décocher Vérrouiller le rapport... et saisir 1024 et 576
    - sur la gauche Format de sortie : Mpeg TS Muxer
    - Fichier > Sauver pour exporter

    Pour coller les deux morceaux, relancer avidemux, ouvrir la vidéo créée précédemment
    - Fichier > Ajouter et sélectionner la vidéo correspondant à l'enregistrement.
    - généralement il faut réencoder tout l'audio car souvent ça se passe mal quand on joint des fichiers, voir la section Sortie Audio sur la gauche.
    - laisser la section Sortie Video en copy
    - Sélectionner le format de sortie Mpeg TS Muxer
    - Fichier > Sauver pour exporter

    Sur le papier c'est simple, mais dans la pratique je ne connait pas la sensibilité du TS à avoir des fichiers légèrement différents, il faut essayer...
     
    #4 MyPOV, 26 Novembre 2017
    Dernière édition: 27 Novembre 2017
  5. Basile

    Points Repaire:
    1 000
    Recos reçues:
    0
    Messages:
    229
    Appréciations:
    +1 / 0 / -0
    Grand merci MyPOV pour ces explications détaillées.

    Je les appliquerai demain, car il faut avoir les idées claires pour ce genre de travail :-) et vous
    tiendrai au courant de mes résultats.

    Bonne nuit.
     
  6. MyPOV

    So

    Points Repaire:
    9 400
    Recos reçues:
    57
    Messages:
    4 794
    Appréciations:
    +290 / 705 / -4
  7. ogt

    ogt
    Conseiller Technique So

    Points Repaire:
    17 200
    Recos reçues:
    499
    Messages:
    21 019
    Appréciations:
    +544 / 1 063 / -30
  8. Basile

    Points Repaire:
    1 000
    Recos reçues:
    0
    Messages:
    229
    Appréciations:
    +1 / 0 / -0
    Bonjour MyPOV et ogt.

    je vous raconte mes malheurs, qui ont débuté peu après ma demande sur le forum:

    - Pour MyPOV: tout content de votre réponse très explicite, je me suis mis au travail avec Avidemux: que je ne connaissais que de nom et qui m' apparu puissant.
    Après une petite prise en main grace à vosnotes, j'ai realisé plusieurs fois une conversion: le fichier original MP4 B et le converti n'avait pas la même taille d'image ni le ni le même nombre d'images/s que le fichier TS A, alors que j'avais entré les paramètres donnés par Mediainfo.
    J'ai mis un très long moment à comprendre...

    Mediainfo me donne pour A:
    - Première piste video: 1024x576, à 25 img/s, AVC(main@L3.1) (CABAC / 2 Ref Frames)
    alors que Avidemux donne:
    - Première piste video: 1920x1080, à 50 img/s, AVC(main@L3.1) (CABAC / 2 Ref Frames)
    assez différent, non ... et qui croire ? Je penche pour Avidemux.

    Et c'est ici qu'intervient ogt avec Mediacoder, pour trancher le débat. Je l'en remercie. J'ai téléchargé ce fichier.

    Sur ces entrefaites, une nouvelle complication, majeure celle-là: mon disque dur de travail pour la video s'est mis à présenter un "Bad sector" et un "Delay", bloquant toute activité sur ce disque.
    Quand tout va mal ...

    Bien sûr, j'ai des sauvegardes, mais je vais tenter de le récupérer d'abord avec des utilitaires.

    Je vous tiens aucourant
     
  9. Basile

    Points Repaire:
    1 000
    Recos reçues:
    0
    Messages:
    229
    Appréciations:
    +1 / 0 / -0
    Bonjour

    J'ai donc repris mes conversions ce matin, après mes déboires avec le disque dur.


    Avec Avidemux, jai modifié le premier fichier de 8', d'origine en MP4 (h264, 854x480, 25 fps, AAC, 128kbps, 44100)
    en TS: (h264, 1920x1080,50fps, AC3, 128kbps, 48000). Avec une seule différence sur l'audio, l'original étant en E-AC3

    Le résultat est excellent et j'ai pu, sans problème, y ajouter les 1h 15' du deuxième film.
    Mais petite surprise à la lecture: dès l'endroit de la jonction, plus de son!

    Pensant a la différence des 2 codecs audio, j'ai téléchargé FFDshow: sans résultat, Avidemus ne devant pas prendre en compte ces codecs "étrangers".

    J'ai donc réencodé le fichier de 1h15 avec Avidemux en AC3, et là, tout est parfait.
    Cerise sur le gateau: j'ai mis les 2 sons au même niveau!

    Tout cela grâce à vous et au Repaire. Je remercie tout le monde.

    Amitiés à tous.
     
  10. MyPOV

    So

    Points Repaire:
    9 400
    Recos reçues:
    57
    Messages:
    4 794
    Appréciations:
    +290 / 705 / -4
    Content que ça fonctionne et d'avoir pu se débrouiller à partir des indications générales dont l'attention à apporter sur le son.
     
  11. Basile

    Points Repaire:
    1 000
    Recos reçues:
    0
    Messages:
    229
    Appréciations:
    +1 / 0 / -0
    OK, merci
     
Chargement...

Partager cette page

Autres contenus

Vous souhaitez annoncer sur le Repaire ? Contactez-nous