module inscription newsletter haut de page forum mobile

Rejeter la notice

Gratuit : Atelier spécial Stabilisation - vendredi 7 juin 14h - 19h
Ne ratez pas notre prochain gros événement ! 
Multi-ateliers : initiations steadicam avec Planning Camera, ateliers pratiques sur gimbal et autres solutions de stab, monitoring et pilotage sur caméras et optiques de cinéma Canon

Infos & inscriptions

[CommentFaire?] récupérer streaming audio

Discussion dans 'Logiciels audio' créé par homero, 17 Octobre 2015.

  1. homero

    So

    Points Repaire:
    16 500
    Recos reçues:
    746
    Messages:
    28 234
    Appréciations:
    +1 095 / 5 638 / -20
    Qui connait un soft gratos pour récupérer l'audio qui passe par la carte son, j'ai essayé NCH Soundtap qui est simple et efficace mais il est payant. D'autres annoncés comme freewares exigent un enregistrement ou refilent des adwares. Je ne vais pas investir alors que j'obtiens d'aussi bons résultats en récupérant la module par la sortie casque du PC et en l'entrant sur mon Zoom H4n (+ 1 mini-boîte de direct).
    Je voudrais faire plus simple et très mobile, j'ai essayé Audacity mais il faut une carte son qui offre le mode mélangeur (mixer) absent de mes 2 PC portables Win 7 64 et Vista 32 (carte son interne AMD ... problème de driver ou fonction non implémentée ?), un essai avec le H4n en carte son externe USB offre ce mode mais pas de module à l'arrivée et comme encombrement, ça revient au même que mon précédent dispositif.
    Autre essai, uniquement avec la fonction magnétophone de Windows, ça fonctionne mais la qualité de la module est sourde et présente du souffle, très moche ...
     
  2. GastonHD

    Points Repaire:
    4 580
    Recos reçues:
    85
    Messages:
    2 347
    Appréciations:
    +19 / 31 / -1
    Bonsoir Homero, :jap:

    Audacity, VLC (flux audio / vidéo et réseau) ... et bien d'autres sont tes amis ;-)
    en revanche tu peut-être pas installé les pilotes ou le paramétrage de Windows et d'audacity sont à vérifer.
    Dans Audacity tu as des options juste au dessus des pistes audio (la partie concernant MME - Micro et hauts parleurs ...) que tu peux configurer dans Windows à partir du panneau de configuration / Matériel Audio /Gérer les périphériques audio et les deux onglets -> Lecture et Enregistrement
    Tu as une capture des onglets "Lecture" et "Enregistrement" ?
    Si le magnéto ne fonctionne pas correctement c'est qu'il y a au départ un problème. :perplexe:

    ;)
     
  3. ogt

    ogtx Regretté conseiller technique
    So

    Points Repaire:
    17 700
    Recos reçues:
    546
    Messages:
    23 512
    Appréciations:
    +712 / 1 396 / -41
    Contrairement à Windows XP, Windows 7 ne permet pas de capturer directement le son issu de la carte, sur la fonction enregistrement.
    Il suffit de relier la sortie HP sur l'entrée ligne de la carte son, avec un câble jacks stéréos, et cela marche alors parfaitement. (sortie verte vers entrée bleue)
    Je ré-enregistre sans problème tout ce qui est généré par la carte son (en particulier en provenance d'Internet), avec n'importe quel logiciel d'enregistrement, dont Adobe Audition et Audacy.
    Eventuellement utiliser un adaptateur en Y si on veut à la fois les Haut-parleurs et l'enregistrement.
    (il faut régler le niveau d'enregistrement pour ne pas avoir de saturation)

    Olivier
     
  4. homero

    So

    Points Repaire:
    16 500
    Recos reçues:
    746
    Messages:
    28 234
    Appréciations:
    +1 095 / 5 638 / -20
    Bon merci à tous deux ça marche avec Audacity en bouclant sortie sur entrée ligne. Seul truc que je ne m'explique pas c'est ma carte son interne (AMD ???) ne m'ait pas offert l'option mélangeur. Il me semble bien que j'avais ça sur un vieux PC tour AMD64 XP 32 SP3 mais la carte son était une Soundblaster haut-de-gamme.
     
  5. GastonHD

    Points Repaire:
    4 580
    Recos reçues:
    85
    Messages:
    2 347
    Appréciations:
    +19 / 31 / -1
    Bonjour Homero, :jap:
    tu as la référence de ton portable ou du chipset audio ?
    Je n'ai pas besoin de faire cette manip sur W7 avec le chipset intégré Realtek :perplexe:

    ;-)
     
  6. ogt

    ogtx Regretté conseiller technique
    So

    Points Repaire:
    17 700
    Recos reçues:
    546
    Messages:
    23 512
    Appréciations:
    +712 / 1 396 / -41
    Moi si, avec aussi un chipset Realtek ALC889
    - pas de problème avec XP,
    - bouclage obligatoire avec W7 ou W10
    Donc le problème est lié à Windows (ou au driver son), pas au chipset son.

    Olivier
     
  7. GastonHD

    Points Repaire:
    4 580
    Recos reçues:
    85
    Messages:
    2 347
    Appréciations:
    +19 / 31 / -1
    je suis sous W7 version intégrale 64bits Sp1 et un chipset RealTek ALC892 (Cf. capture en fichier lié) :
    aucun problème de capture audio, ni besoin de faire du bricolage avec un quelconque bouclage et heureusement d'ailleurs, la préhistoire de l'informatique est loin derrière nous !!!
    En plus du pilote, il y a généralement un gestionnaire audio à installer pour avoir toutes les fonctionnalités spécifiques au chipset audio disponibles.

    ;-)

    Gaston
     

    Fichiers attachés:

  8. homero

    So

    Points Repaire:
    16 500
    Recos reçues:
    746
    Messages:
    28 234
    Appréciations:
    +1 095 / 5 638 / -20
    Les ordis sont des portables Acer Aspire 8920G sous Win 7 64 bits SP1

    Nom AMD High Definition Audio Device
    Fabricant Advanced Micro Devices
    Statut OK
    ID du périphérique Plug-and-Play HDAUDIO

    \FUNC_01&VEN_1002&DEV_AA01&SUBSYS_00AA0100&REV_1000\5&32CB7760&0&0001
    Pilote c:\windows\system32\drivers\atihdw76.sys (7.12.0.7705, 93,02 Ko (95 248 octets), 05/12/2011 20:47)
    Nom Périphérique High Definition Audio
    Fabricant Microsoft
    Statut OK
    ID du périphérique Plug-and-Play HDAUDIO

    \FUNC_01&VEN_10EC&DEV_0889&SUBSYS_10250145&REV_1000\4&14473EBE&0&0001
    Pilote c:\windows\system32\drivers\hdaudio.sys (6.1.7601.17514, 342,00 Ko

    (350 208 octets), 21/11/2010 04:23)

    Egalement son frère Acer Aspire 8930G sous Vista 32 SP1 (ou 2 faut que je contrôle) en dual boot Linux Mint 17.
    Je n'ai pas refait de tests avec ce dernier depuis hier

    Nom Realtek High Definition Audio
    Fabricant Realtek
    Statut OK
    ID du périphérique Plug-and-Play HDAUDIO\FUNC_01&VEN_10EC&DEV_0889&SUBSYS_10250145&REV_1000\4&32A4A68B&0&0001
    Pilote c:\windows\system32\drivers\rtkvhda.sys (6.0.1.5618, 2,04 Mo (2 134 424 octets), 17/07/2008 10:23)

    Nom NVIDIA High Definition Audio
    Fabricant NVIDIA
    Statut OK
    ID du périphérique Plug-and-Play HDAUDIO\FUNC_01&VEN_10DE&DEV_0006&SUBSYS_10DE0101&REV_1000\4&32A4A68B&0&0201
    Pilote c:\windows\system32\drivers\nvhda32v.sys (1.3.30.1, 158,78 Ko (162 592 octets), 25/09/2015 19:26)


    Dans la config audio "enregistrement" n'apparaissent que micro et entrée ligne sur les 2 portables. Pas plus d'infos sur le chip audio avec l'utilitaire Speecy.
     
    #8 homero, 18 Octobre 2015
    Dernière édition: 19 Octobre 2015
  9. GastonHD

    Points Repaire:
    4 580
    Recos reçues:
    85
    Messages:
    2 347
    Appréciations:
    +19 / 31 / -1
    Bonjour Homero,:jap:

    ton chipset audio est a priori un realtek :
    Acer Aspire 8920G -> Realtek ALC889A Intel HD Audio
    Acer Aspire 8930G -> ALC 889a
    Tu peux trouver les dernière mises-à-jour ici :
    http://www.realtek.com.tw/downloads...4&Level=4&Conn=3&DownTypeID=3&GetDown=false#1

    ou ici pour les AC97 et high Definition Audio là :
    Realtek

    mais si la mise à jour a été effectuée via Windows Update et que tu n'as pas de problème particulier, ce n'est pas nécessaire d'effectuer la mise-à-jour.

    Pour activer le Mixage stéréo :
    Peux-tu aller dans l'onglet "Enregistrement" bouton droit de la souris dans l'onglet puis "Afficher les périphériques désactivés" normalement tu devrais retrouver le périphérique Mixage Stéréo.
    Tu te positionnes dessus, bouton droit de la souris dans le "menu contextuel" tu cliques sur "Activer".

    Tu peux retrouver les pilotes, Bios, manuel... plus ou moins à jour sur le site Acer pour tes 2 portables ici :
    Téléchargement de pilotes et manuels | Site officiel Acer
    Tu sélectionnes dans la liste Ordinateur portable/Aspire/Aspire 8920G ou Aspire 8930G

    ;-)
     
    #9 GastonHD, 19 Octobre 2015
    Dernière édition: 19 Octobre 2015
    • Je recommande ! Je recommande ! x 1
  10. homero

    So

    Points Repaire:
    16 500
    Recos reçues:
    746
    Messages:
    28 234
    Appréciations:
    +1 095 / 5 638 / -20
    Génial, j'a appliqué tes conseils après avoir été chercher les nouveaux gestionnaires sur le site de Realtek et le mixer est apparu (ce qui n'était pas le cas auparavant) ça marche sur le PC 8930G ! Le son est nickel avec Audacity.... :bravo: Je suis en train de procéder sur le 8920G ... Après ça sera le tour pour Linux.
    Merci malgré toutes mes recherches je n'avais pas trouvé sur le Web d'explications aussi concises !

    Edit : OK sur le 8920G dont je n'aurais jamais deviné que c'était également une Realtek !
     
    #10 homero, 19 Octobre 2015
    Dernière édition: 19 Octobre 2015
  11. ogt

    ogtx Regretté conseiller technique
    So

    Points Repaire:
    17 700
    Recos reçues:
    546
    Messages:
    23 512
    Appréciations:
    +712 / 1 396 / -41
    Bon, pour une fois je vais accorder un satisfécit à GastonHD. :love:
    Je n'avais installé pour le chipset son que les drivers du CD livré avec la carte mère Gigabyte :
    - Avec XP ces drivers avaient bien installé le périphérique d'enregistrement Mixage Audio.
    - Sur W7 et W10 ce périphérique n'a pas été installé, d'où ma solution de contournement par un câble de bouclage.

    Je viens de faire la mise à jour avec la dernière version des drivers Realtek, et là, le périphérique Mixage stéréo apparait bien, donc solution identique à XP. (donc le bouclage se fait en interne au lieu de passer par le câble).

    Olivier
     
  12. GastonHD

    Points Repaire:
    4 580
    Recos reçues:
    85
    Messages:
    2 347
    Appréciations:
    +19 / 31 / -1
    Bonsoir Homero,:jap:
    tant mieux qu'Audacity fonctionne correctemernt maintenant, c"est un super outil aux ressources insoupçonnées, bien que l'interface pourrait être améliorée.
    ;-)
    Ben Ogt qu'est-ce qui se passe ? ooo T'as une carence affective en ce moment ? :D
    Faut essayer le chocolat !!! :good:
    Je suis touché par cette déclaration :cry2:et je sais que rien n'est plus beau que l'amour entre deux vieux soldats !!! :good:
    Mais malgeureusement je ne suis pas un vieux soldat (du moins pas encore !) .... et tu n'es pas mon type d'homme.:non: :rolleyes:

    ;-)
     
  13. homero

    So

    Points Repaire:
    16 500
    Recos reçues:
    746
    Messages:
    28 234
    Appréciations:
    +1 095 / 5 638 / -20
    J'utilise Audacity depuis quelques années, plus rarement depuis que j'ai profité d'une promo à 10 € de Soundforge Audiostudio 10.0 plus ergonomique et qui possède un plug-in Izotope, d'alleurs je viens de le tester en capture de flux ainsi que Cyberlink Audio Director et ça fonctionne désormais dans les deux cas.
    Par rapport à l'écoute du direct, je note sur le fichier enregistré sur le 8920G une légère réverbe entraînant moins de présence et surtout remontée d'une très faible fréquence basse continue qu'il sera facile de corriger. Ce n'est pas le cas sur le 8930G qui m'a paru plus fidèle par rapport au direct. Faut que je fouille dans les réglages d'enregistrement.
    Pour Linux pas encore de résultats mais ça tient à mon incapacité de débutant (provisoire j'espère) à gérer les paquets et le mode console ...
     
    #13 homero, 20 Octobre 2015
    Dernière édition: 20 Octobre 2015
  14. GastonHD

    Points Repaire:
    4 580
    Recos reçues:
    85
    Messages:
    2 347
    Appréciations:
    +19 / 31 / -1
    Bonjour Homero, :jap:
    Normalement lorsque ta partie audio est bien réglée, du magnétophone de Windows, aux autres logiciels audio tout devrait fonctionner correctement.


    Lorsque tu récupères ton flux, il faut bien vérifier que tu ne récupères pas par la même occasion le flux audio du micro et des autres périphériques gérés par le mixer... çà a pour conséquence d'ajouter un effet "pédale Wah Wah" à ta capture. Si tu as ce genre de problème tu peux les régler via audacity en désactivant les périphériques en cause au niveau des popups :
    http://manual.audacityteam.org/o/m/images/a/aa/devicetoolbarwin7basic.png

    ou dans les onglets "Enregistrement" et "Lecture" du gestionnaire Audio de Windows



    Bienvenue chez Linux !!!
    Tu as réussi à traiter le problème ?

    ;-)
     
  15. homero

    So

    Points Repaire:
    16 500
    Recos reçues:
    746
    Messages:
    28 234
    Appréciations:
    +1 095 / 5 638 / -20
    Pour la réverbe ça me semble aller mieux après avoir carrément mis sur off ligne et micros ...
    Pour Linux, après avoir installé Pavucontrol, je ne récupère toujours pas le streaming, il doit me manquer des éléments mais je suis à fond dans la doc ...
     
Chargement...

Partager cette page

Dernières Occasions

 
Vous souhaitez annoncer sur le Repaire ? Contactez-nous