module inscription newsletter haut de page forum mobile

Rejeter la notice

ateliers live resolve avec forest

Ateliers Live Resolve - Formez-vous en ligne tous les mois avec Forest !
Faites rapidement évoluer la qualité de vos étalonnage avec nos ateliers mensuels de 3h.
Toutes les infos

Problème export de fichiers animés : H.264 et H.265

Discussion dans 'Adobe After Effects' créé par Smartin, 16 Mars 2022.

  1. Smartin

    Points Repaire:
    550
    Recos reçues:
    0
    Messages:
    48
    Appréciations:
    +0 / 1 / -0
    Bonsoir à tous,

    Je suis en train de créer une série de petites animations d'environ 6 à 12 s, destinées à être proposées en tant qu'NFTs. Ces animations sont assez simples, issues de créations dans des fichiers vectoriels, et animées dans After Effects au format 4000x4000 pixels. Le processus de création ne me pose pas de problème, mais je bloque au niveau du rendu dans le Media Encoder.

    Tout d'abord j'ai effectué des rendus "classiques" au format H.264 (avec une préfiguration "correspondance à la source" + "rendre à la profondeur maximale" + "utiliser la qualité de rendu maximale"). Là je me retrouve avec un bug étrange : lors des 2 premières secondes, il y a une sorte de texture de petits points qui apparaît sur une partie de mon image (la surface rouge la plus grande) - voir photo. Cet "artefact" disparaît peu à peu par la suite... (C'est très peu visible mais ça suffit pour bien prendre la tête : ce n'est clairement pas propre :o ...)

    Je viens d'exporter en H.264 et sans les optimisations diverses évoquées au-dessus. Résultat : idem.
    Je fais aussi en ce moment une tentative avec 2 passages (mais vu le temps que ça prendra... autant essayer de trouver une autre solution...)

    Enfin, si j'exporte en H.265 - ce qui m'a semblé être conseillé ici ou là (à raison ?) - là cet artefact disparaît, mais je suis confronté à une série de difficultés pour bien lire le mp4 final sur mon ordinateur.
    - J'ai bien installé dans windows l'extension HEVC Video Extension
    - Avec le lecteur VLC ça bugue (bien que l'option "décodage matériel : accélération vidéo directX DXVA 2.0" soit bien cochée),
    - Avec le lecteur Windows Média, la boucle ne fonctionne pas, (et d'ailleurs en mode H.264, si la boucle fonctionne, il y a comme un "heurt" entre la fin et le début de l'animation. Bref c'est tout sauf fluide...)
    J'en viens à me demander si c'est si opportun que ça d'exporter à ce format, car si qq'un récupère l'une de mes animations je me dis qu'il y a pas mal de chance qu'il ne parvienne pas à la lire correctement...

    Donc pour résumer : en mode H.264 le mp4 est lisible mais il y a un bug dans le rendu, en mode H.265 pas de bug de rendu, mais bugs divers à la lecture.

    Que me conseilleriez-vous ? :-/
     

    Fichiers attachés:

  2. mhr

    mhr
    So

    Points Repaire:
    7 450
    Recos reçues:
    65
    Messages:
    1 180
    Appréciations:
    +110 / 533 / -0
    Si c est pour monnayer des oeuvres numériques, l acheteur est en droit d exiger un meilleur format qu un pauvre H264 ou H265, c est comme si tu vendais une peinture à la gouache sur une simple nappe en papier au lieu d une huile vernis sur une toile enduite encadrée
    Choisis un format peu compressé pour ton Master, type AVi non compressé, Apple ProRes 444., DNxHR HQX, ou même QuickTIME Animation, ensuite de ce master tu fais des H264,265, pour visualisation, si besoin à la demande
     
  3. Smartin

    Points Repaire:
    550
    Recos reçues:
    0
    Messages:
    48
    Appréciations:
    +0 / 1 / -0
    Merci pour ces bons conseils. J'ai beaucoup à apprendre dans le domaine de la vidéo ;-) !

    Je serai partant pour l'AVI non compressé, mais il me semble qu'il apparaît une limitation de 1920x1080 px non ? Bref pour moi qui suit sur des formats carrés (de 4000 par 4000 en fichier natif), ça me fait redescendre à 1080x1080 maxi. J'ai sans doute loupé un truc ?

    Suite : après recherche il me semble que la plupart des plateformes de NFTs demandent des formats MP4 (voire MP3) et GIF , mais pas d'autres formats (pour les animations j'entends)
     
  4. Alcoriza

    So

    Points Repaire:
    8 200
    Recos reçues:
    97
    Messages:
    5 202
    Appréciations:
    +291 / 696 / -5
    Quand je regarde les specs :

    [​IMG]

    Il apparait que tu fais pas ce que tu veux.
     
  5. mhr

    mhr
    So

    Points Repaire:
    7 450
    Recos reçues:
    65
    Messages:
    1 180
    Appréciations:
    +110 / 533 / -0
    Absolument pas, mais c est de lire ton fichier en temps réel à cette résolution, qui va être compliqué.
    Quelque soit les types de fichiers que l on te demande par la suite, il faut que tu conserves ton animation sous la forme d un master , à partir duquel tu recalcules des fichiers dans le format et compression demandé
     
  6. Smartin

    Points Repaire:
    550
    Recos reçues:
    0
    Messages:
    48
    Appréciations:
    +0 / 1 / -0
    Salut à vous. Je comprends bien le principe, et que même si la plateforme n'accepte que le mp4, il faut un fichier "master". Par contre je ne parviens pas à passer au-delà du format 1920x1080 dans le Media Encoder, si j'opte pour l'Avi non-compressé. Si je tape manuellement 4000px, ça me remet 1920px. J'ai manqué une étape ?
     
  7. mhr

    mhr
    So

    Points Repaire:
    7 450
    Recos reçues:
    65
    Messages:
    1 180
    Appréciations:
    +110 / 533 / -0
    ne passe pas par media encoder, fais le calcul du film dans after effect
     
    #7 mhr, 17 Mars 2022
    Dernière édition: 17 Mars 2022
  8. Smartin

    Points Repaire:
    550
    Recos reçues:
    0
    Messages:
    48
    Appréciations:
    +0 / 1 / -0
    Salut. J'ai bien suivi ces conseils et merci, c'est en bonne voie.

    D'abord je passe par AE et non le Media Encoder comme conseillé, et là mon fichier sort bien en 4000x4000 (j'ai pris l'avi non compressé).
    Difficile d'être sûr à 100% que l'animation qui en résulte soit nickel, vu que ma station a des perfs limitées. De plus VLC est à la rue dans le plupart de mes visualisations depuis le début de mes opérations (suis même obligé de le réinstaller à chaque bug car il n'apparaît pas dans le gestionnaire des tâches après un bug). Curieusement le lecteur de Windows s'en sort mieux.
    En tous cas ce qui est sûr c'est que dans ce que je peux voir avec le lecteur windows, la qualité d'image en avi est nickel. A côté de ça il me semble que l'animation est fluide et sa boucle se fait bien (sans qu'on la remarque).

    Pour l'étape suivante je suis parti de cet avi et l'ai exporté toujours à 4000x4000 px.
    J'ai fait un essai en H.264 puis H.265 :
    - Mes "artefacts" dont je parlais en début de post sont bien disparus, ça c'est très positif.
    - En visualisation du mode H.264, j'ai des sauts à la fin de chaque cycle de lecture (un fond noir) si je lis avec VLC. Avec le lecteur Windows la boucle est plus fluide, mais j'ai un saut de qualité entre la fin et le début d'une boucle (les tonalités de couleurs changent un peu, ça "saute"). Bref la boucle déconne...
    - La qualité du rendu en H.265 me semble bien meilleure, j'ai donc zappé le H.264
    - Par contre la visualisation de l'animation n'est pas bonne. Avec VLC ça plante au bout de 3-4 secondes, sur une image qui paraît fixe. Avec le lecteur Windows l'animation, la boucle ne fonctionne qu'une fois (puis l'image se bloque à l'infini).
    Donc encore du mal à voir si j'ai un produit valable (j''en doute fort :o )

    Je vais tester sur des exports à 2000x2000 pour voir les différences (à 1200x1200 la qualité de mon image n'est déjà plus là...)
     
  9. Smartin

    Points Repaire:
    550
    Recos reçues:
    0
    Messages:
    48
    Appréciations:
    +0 / 1 / -0
    J'ai téléchargé d'autres vidéos en ligne. J'ai les mêmes soucis de visionnage avec les 2 players dont je dispose. Donc à priori ce sont eux qui sont défaillants :o

    Est-ce que l'idée d'aller mettre en ligne mes fichiers peut être la bonne idée pour bien les voir (dans un navigateur tel que Chrome,...) ?

    Edit : j'ai mis les 2 animation H264 et H265 en ligne. Dans chrome, la 1ère est ok mais n'est pas lue en boucle. Et la 2nde (H265) ne fonctionne pas du tout. Donc j'ai un peu les mêmes résultats qu'avec les players en fait. Et sous thunderbird j'ai carrément un signalement de fichiers corrompus :-/
     
    #9 Smartin, 18 Mars 2022
    Dernière édition: 18 Mars 2022
  10. jakin1950

    So

    Points Repaire:
    5 050
    Recos reçues:
    41
    Messages:
    2 033
    Appréciations:
    +159 / 353 / -4
    pour VLC , utiliser la dernière version à jour
     
  11. Smartin

    Points Repaire:
    550
    Recos reçues:
    0
    Messages:
    48
    Appréciations:
    +0 / 1 / -0
    Oui, c'est ce que j'ai fait je crois 2 fois depuis 10 jours.
    Ca bugue un peu de partout en fait tout ça...
     
  12. LiquidPro

    So

    Points Repaire:
    15 325
    Recos reçues:
    291
    Messages:
    2 704
    Appréciations:
    +277 / 855 / -3
    Quelle est la machine que tu utilises ? (modèle, référence, ou éléments si c'est une machine montée)

    Parce-que pour lire une vidéo en 4000x4000 pixels compressée avec un codec de diffusion, il faut une certaine puissance (de calcul). Pour lire la même vidéo en format peu ou pas compressé aussi (en terme de débit).

    VLC c'est pas un modèle d'optimisation. Sous Windows, MPC-HC est un peu plus véloce, mais ne fera pas de miracles si la machine est vraiment trop faible.
     
  13. Smartin

    Points Repaire:
    550
    Recos reçues:
    0
    Messages:
    48
    Appréciations:
    +0 / 1 / -0
    Bonsoir.

    Je bosse sur un portable Acer Travelmate d'il y a 5-6 ans, avec un i5-5200U, 8 Go de mémoire vive, un petit ssd de 120 Go, un HDD de 1 To, et j'ai un processeur graphique HD Graphics 5500 (qui n'est plus mis à jour et qu'After n'aime pas trop...) et une GeForce 940.

    Et je n'ai plus beaucoup de place sur mes 2 DD : restent 10-15 Go sur le SSD, et environ 50 sur le HDD (les 2 sont dans le rouge...).
     
  14. LiquidPro

    So

    Points Repaire:
    15 325
    Recos reçues:
    291
    Messages:
    2 704
    Appréciations:
    +277 / 855 / -3
    C'est sûr que c'est pas une configuration d'enfer. J'ai un petit portable un tout petit peu plus performant (i5-5287U, Iris Graphics 6100), c'est déjà bien difficile de lire une vidéo UHD (3840x2160) encodée en HEVC (très lent à démarrer, saccades, on sent vraiment que la machine lutte), pas étonnant que ce soit bien compliqué sur la votre.

    C'est normal que le problème se retrouve partout. Dans une page Web, c'est la machine qui décode la vidéo, pas le serveur, ça nécessite la même puissance de calcul que de la lire en local.
     
  15. Smartin

    Points Repaire:
    550
    Recos reçues:
    0
    Messages:
    48
    Appréciations:
    +0 / 1 / -0
    Bonjour.

    C'est vrai que la machine ici lutte, pour lire l'avi en particulier (pour les autres non, pas trop), mais malgré tout ce sont toujours et avant tout les exports mp4 - donc les plus légers - qui buguent. Vu que l'export en mode H.265 me sort carrément des fichiers annoncés comme corrompus, tandis que l'export en H.264 me renvoie des fichiers dont la fin de la lecture est heurtée, avec carrément un fond tout noir pendant un laps de temps (avant que la boucle ne reparte de zéro).

    J'en profite au passage pour poser une question, concernant les boucles d'une animation réalisée sous AE. Pour qu'une animation soit lue en boucle par défaut dans n'importe quel player externe, il n'y a rien à faire côté source (AE), c'est juste l'utilisateur qui devra mettre son lecteur en position "boucle". Est-ce exact ?
    Ou bien y a-t-il moyen, dans AE, de "forcer" la lecture en boucle d'une composition sur un player externe (avec les loopout (), les remappages temporels, etc.) ?
     
Chargement...

Dernières occasions

 

Partager cette page

Dernières Occasions

 
Vous souhaitez annoncer sur le Repaire ? Contactez-nous